Bug 157709 - Installer, text mode: ImportError: No module named email.Utils
Installer, text mode: ImportError: No module named email.Utils
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-05-13 18:09 EDT by Igor Bukanov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-11 14:13:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Igor Bukanov 2005-05-13 18:09:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
I tried to install FC4 test4 on Sony Vaio PCG-Z505R notebook with 128 MB and text mode installer always crashes with python stack trace starting at:

ImportError: No module named email.Utils
File /usr/lib/python2.4/urllib2.py line 1131 in open_local_file

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
To install I used DVD image stored on /dev/hda2 (I do not have CDROM!). To boot I copied vmlinuz and initrd.img from /images/pxeboot from FC4-test3-i386-DVD.iso to a directory on the harddrive and then added them to grub menu. 

During text mode installation I asked the installer to reinstall to /dev/hda1 which I normally use for scratch data and choosed reformat the partion as /dev/ext3. I askd to install grub to /dev/hda1 as well. Then I tried various options but it alway terminated with the above stack trace.

Actual Results:  After the installer tried to build a package list it terminated with Python stack trace.

Expected Results:  The installer should proceed to the package selection.

Additional info:
Comment 1 Jeremy Katz 2005-05-16 16:41:23 EDT
Fixed in CVS, although this should only be getting hit in error cases.
Comment 2 Igor Bukanov 2005-05-16 16:52:15 EDT
(In reply to comment #1)
> Fixed in CVS

Any chance to try the images with fixes? I do not have time to learn how to
compile anakonda from CVS :(
Comment 3 Alan 2005-07-22 22:19:09 EDT
Yea, I have the same problem, and I can't to fix it, cause I can't compile 
Anaconda from CVS, because I don't have Linux. May be anyone can attache fixed 
vmlinuz and initrd.img?
Comment 4 Alan 2005-07-26 10:48:58 EDT
I downloaded development releases of vmlinuz and initrd.img from fedora mirror 
in development folder, but new vmlinuz and initrd.img prints error, that 
install system cann't found Fedora Core 4 ISOs...
Comment 5 Chris Lumens 2005-10-11 14:13:44 EDT
Fixed in CVS, hopefully for real this time.
Comment 6 dennis 2005-10-13 13:58:44 EDT
Bug remains, tried to install FC4 for the last 5 days (thanks for making it such
a pain in the butt for those who cannot boot from usb pen, dont have a cdrom
drive and dont have a cd burner). I found a workaround to do a 1-floppy install
by using a random linux boot disk and dd the diskboot.img to a temporary
bootable partition created by fdisk. However after finally getting the installer
to run, I now run in this script error. I'm going to try and use those dev
images to see if that works... got no other choice now do I? Since this might be
a low ram-related error Im going to swap a memory module from my other computer
and see if it helps any.

How to reproduce:
Machine is a 366 Celeron with 128mb ram, 3x160gb, 1x80gb and 1x40gb hard drive,
3x100mbit network card.

Download floppy.syslinux.bin from
dd if=floppy.syslinux.bin \\?\A: (using windows version of dd)

Download FC4-i386-disc1.iso thru FC4-i386-disc4.iso and placed these on a
temporary partition (/dev/hda1 in my case)

Boot computer from floppy, mount FC4-i386-disc1.iso to /cdrom
dd if=/cdrom/images/bootdisk of=/dev/hda2 (128 meg bootable partition)

Remove floppy, reboot, installer will run.

Selected text mode install, server setup. No matter what I choose during install
it will fail with: "ImportError: No module named email.Utils
File /usr/lib/python2.4/urllib2.py line 1131 in open_local_file"

Note You need to log in before you can comment on or make changes to this bug.