Bug 1577252 - Anaconda sets incorrect system time during RHEL7 installation
Summary: Anaconda sets incorrect system time during RHEL7 installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 14:40 UTC by mertensb.mazda
Modified: 2018-05-15 07:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 07:10:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
date/time screen showing the manually corrected time during installation (393.08 KB, image/png)
2018-05-11 14:40 UTC, mertensb.mazda
no flags Details
screenshot showing timedatectl and hwclock output (78.78 KB, image/png)
2018-05-11 14:43 UTC, mertensb.mazda
no flags Details

Description mertensb.mazda 2018-05-11 14:40:30 UTC
Created attachment 1434966 [details]
date/time screen showing the manually corrected time during installation

Description of problem:
System and hardware time set by anaconda are wrong.
I.e. The time set is not what was configured during installation.

Version-Release number of selected component (if applicable):
Installation using RHEL7.0 ISO

How reproducible:
Has occurred every time on RHEL 7 installations on VMWare ESX.

Steps to Reproduce:
1. Create new Virtual Machine
2. Install RHEL7 from ISO (RHEL 7.0 ISO)
3. Set timezone and time

Actual results:
The time after the installation is wrong
e.g. time set in anaconda: 16:00, timezone Europe/Brussels (UTC +2)
After installation time is set to 18:00 CEST

Expected results:
Time set as entered in the anaconda date/time screen

Additional info:
It looks like either the clock on the date/time screen is always in UTC (and does not match the timezone selected).
Or the UTC offset is applied twice.
The timezone on the VMWare host is set to UTC.
The time displayed during installtion is the UTC time, during installation I changed the time from (in this example) 14:00 to 16:00.

Comment 2 mertensb.mazda 2018-05-11 14:43:02 UTC
Created attachment 1434967 [details]
screenshot showing timedatectl and hwclock output

Comment 3 Jiri Konecny 2018-05-14 07:28:27 UTC
Hello,

Could you please test this on a newest RHEL 7 version. There were plenty of changes since then and there's a big probability that this issue is fixed already.

Thank you.

Comment 4 mertensb.mazda 2018-05-14 19:50:45 UTC
Hi,

I'm unable to reproduce the problem with the RHEL7.5 binary DVD ISO.

The date/time wizard of RHEL7.0 shows the UTC time initially, in RHEL7.5 it shows the correct local time as soon as the correct time zone is selected.

Regards

Bram

Comment 5 Samantha N. Bueno 2018-05-15 07:10:58 UTC
Thanks for the update. I'll suggest that you use the latest version of RHEL in this case. As Jiri said in comment 3, numerous bugs have been fixed since 7.0 was originally released.


Note You need to log in before you can comment on or make changes to this bug.