Bug 1577272 - Installer fails on Control plane install
Summary: Installer fails on Control plane install
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 15:06 UTC by Vikas Laad
Modified: 2018-05-11 17:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 17:00:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log with -vvv (1.73 MB, text/plain)
2018-05-11 15:09 UTC, Vikas Laad
no flags Details

Description Vikas Laad 2018-05-11 15:06:17 UTC
Description of problem:
Control plan install failing, plese see ansible log for details.

Version-Release number of the following components:
rpm -q openshift-ansible
commit f9736b5992ef80aed71f415671dff95b4732b508

rpm -q ansible
ansible-2.4.3.0-1.el7ae.noarch

ansible --version
ansible 2.4.3.0
  config file = /root/openshift-ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  4 2018, 09:38:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-34)]

How reproducible:
Always

Steps to Reproduce:
1. checkout openshift-ansible latest
2. start deploy_cluster playbook

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Vikas Laad 2018-05-11 15:09:01 UTC
Created attachment 1435002 [details]
ansible log with -vvv

Comment 3 Scott Dodson 2018-05-11 16:31:05 UTC
Vikas,

discussed w/ Urvashi, it looks like you've configured cri-o to use cgroupfs rather than systemd? Did you do this deliberately as the installer should be configuring /etc/crio/crio.conf to set cgroup_manager=systemd.

Comment 4 Scott Dodson 2018-05-11 16:31:51 UTC
Do you have logs from the prerequisites playbook that would've set crio up?

Comment 5 Urvashi Mohnani 2018-05-11 16:44:31 UTC
The contents of /etc/crio/crio.conf would be helpful also.

Comment 6 Vikas Laad 2018-05-11 17:00:56 UTC
prerequisites playbook failed due to following error, I am re-run it and it succeeded

fatal: [ec2-54-190-196-65.us-west-2.compute.amazonaws.com]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: 'pause_image' is undefined"}

After that i ran deploy playbook again and cluster was created fine. Closing this bz.


Note You need to log in before you can comment on or make changes to this bug.