Bug 1577284 - falkon crashes on start
Summary: falkon crashes on start
Keywords:
Status: CLOSED DUPLICATE of bug 1570389
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine
Version: 28
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 15:33 UTC by Peter Gückel
Modified: 2018-05-11 17:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 17:21:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Gückel 2018-05-11 15:33:02 UTC
Description of problem:
When falkon is called to action, it crashes instantly.

Version-Release number of selected component (if applicable):
falkon-3.0.1-1.fc28.x86_64

How reproducible:
start and nothing happens. The first time, a brief window might appear that quickly vanishes without an error message; thereafter, nothing happens.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
when run from the command line, this output is generated:

WebEngine compiled with X11 support, however qpa backend is not xcb. This may fail.
[0511/092736.949984:WARNING:stack_trace_posix.cc(648)] Failed to open file: /home/peter/#1066212 (deleted)
  Error: No such file or directory
[6871:6896:0511/092736.998192:ERROR:gl_implementation.cc(246)] Failed to load /usr/bin/libGLESv2.so: /usr/bin/libGLESv2.so: cannot open shared object file: No such file or directory
Falkon: 1 extensions loaded
[6871:6896:0511/092737.578798:ERROR:gl_surface_qt.cpp(701)] Requested OpenGL implementation is not supported. Implementation: 0
*** stack smashing detected ***: <unknown> terminated
Received signal 6
#0 0x7f5f52ba1e76 <unknown>
#1 0x7f5f52ba17e9 <unknown>
#2 0x7f5f52ba1dfc <unknown>
#3 0x7f5f4e122fd0 <unknown>
#4 0x7f5f4e122f4b __GI_raise
#5 0x7f5f4e10d591 __GI_abort
#6 0x7f5f4e165b0b __libc_message
#7 0x7f5f4e1f782d __GI___fortify_fail_abort
#8 0x7f5f4e1f77e4 __stack_chk_fail_local
#9 0x7f5f51918123 <unknown>
#10 0x7f5f534c9d47 <unknown>
#11 0x7f5f534d6a8e <unknown>
#12 0x7f5f534d9344 <unknown>
#13 0x7f5f534da55f <unknown>
#14 0x7f5f534d40f0 <unknown>
#15 0x7f5f534d47f8 <unknown>
#16 0x7f5f534d399f <unknown>
#17 0x7f5f534d5d25 <unknown>
#18 0x7f5f52c2303b <unknown>
#19 0x7f5f52bbdbf0 <unknown>
#20 0x7f5f52bbde6d <unknown>
#21 0x7f5f52bbf11e <unknown>
#22 0x7f5f52bc03d1 <unknown>
#23 0x7f5f52bdd95d <unknown>
#24 0x7f5f52bf80ef <unknown>
#25 0x7f5f52bf37cb <unknown>
#26 0x7f5f4ded4564 start_thread
#27 0x7f5f4e1e631f __GI___clone
  r8: 0000000000000000  r9: 00007f5ee7ffd6a0 r10: 0000000000000008 r11: 0000000000000246
 r12: 0000000000001000 r13: 00007f5ee7ffd940 r14: 0000000000000040 r15: 00007f5f10098000
  di: 0000000000000002  si: 00007f5ee7ffd6a0  bp: 00007f5ee7ffda80  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f5f4e122f4b  sp: 00007f5ee7ffd6a0
  ip: 00007f5f4e122f4b efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Comment 1 Kevin Kofler 2018-05-11 17:21:17 UTC

*** This bug has been marked as a duplicate of bug 1570389 ***


Note You need to log in before you can comment on or make changes to this bug.