Bug 15774 - 'nousb' kernel command line arg ignored
Summary: 'nousb' kernel command line arg ignored
Status: CLOSED DUPLICATE of bug 15464
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-08 21:39 UTC by Andrew Sheaff
Modified: 2014-03-17 02:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 21:39:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Sheaff 2000-08-08 21:39:29 UTC
rc.sysinit does not recognize the kernel command line argument 'nousb'.

My solution:  On line 148, which reads:

if [  grep -v "nousb" /proc/cmdline 2>/dev/null ]; then

should not be using the test command '[]'.  It should be using the
expression operator '()'.  The line should be:

if (  grep -v "nousb" /proc/cmdline 2>/dev/null ); then

Comment 1 Bill Nottingham 2000-08-08 21:49:55 UTC

*** This bug has been marked as a duplicate of 15464 ***


Note You need to log in before you can comment on or make changes to this bug.