Bug 1577455 - Wrong upgrade path for ghostscript-devel
Summary: Wrong upgrade path for ghostscript-devel
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 28
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Martin Osvald 🛹
QA Contact: qe-baseos-daemons
: 1579117 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2018-05-12 06:55 UTC by Mattia Verga
Modified: 2019-02-08 08:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-02-08 08:40:44 UTC
Type: Bug

Attachments (Terms of Use)

Description Mattia Verga 2018-05-12 06:55:51 UTC
While trying to do a system-upgrade from F27 to F28 I get:

 Problema: package ghostscript-devel-9.22-4.fc27.x86_64 requires ghostscript(x86-64) = 9.22-4.fc27, but none of the providers can be installed
  - ghostscript-9.22-4.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package ghostscript-devel-9.22-4.fc27.x86_64

Looking at the specfile, I think there's an error in the Obsoletes and Conflicts statment of libgs-devel.
Accordingly to https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages the Obsoletes statement should point to a higher version number than the last released one.
So it should be:
Obsoletes: ghostscript-devel <= 9.22-5

instead of
Obsoletes: ghostscript-devel < 9.22-4

In the latter case, the current F27 version, which is 9.22-4, is not properly Obsoleted.

Comment 1 Igor Gnatenko 2018-05-12 06:59:42 UTC
<= is bad idea, it should be just `< 9.22-5`

Comment 2 Mattia Verga 2018-05-12 08:49:06 UTC
(In reply to Igor Gnatenko from comment #1)
> <= is bad idea, it should be just `< 9.22-5`

So, the example on the Packaging Guidelines is probably wrong:
'Obsoletes: foo <= 2:1.0-4   # Important: We set the Obsoletes release to 4 to be higher than the previous Release: 3%{?dist}'

Comment 3 David Kaspar // Dee'Kej 2018-05-14 10:29:39 UTC
Hey Mattia,

thanks for the report! :)

(In reply to Igor Gnatenko from comment #1)
> <= is bad idea, it should be just `< 9.22-5`

Yeah, I don't like the '<=' either. I'll change it to 9.22-5. IMHO it should be sufficient.

Comment 4 Fedora Update System 2018-05-14 10:58:12 UTC
ghostscript-9.23-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39e37799a3

Comment 5 Fedora Update System 2018-05-14 20:39:35 UTC
ghostscript-9.23-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-39e37799a3

Comment 6 Colin Macdonald 2018-05-17 06:38:15 UTC
*** Bug 1579117 has been marked as a duplicate of this bug. ***

Comment 7 David Kaspar // Dee'Kej 2018-05-17 10:37:22 UTC
The update of this is currently being blocked because of new release of libidn, which has to be released at the same time as ghostscript.

Comment 9 Martin Osvald 🛹 2019-02-08 08:40:44 UTC

This looks to be in some kind of strange ON_QA limbo state for a very long time (~9 months) and it appears it is fixed already, therefore I am closing this as CURRENTRELEASE.

Please, feel free to reopen this bug if you still see some problems regarding this.

Thank you and regards,

Note You need to log in before you can comment on or make changes to this bug.