Bug 1577463 - [abrt] iwl_pcie_rx_handle: WARNING: CPU: 0 PID: 538 at drivers/net/wireless/intel/iwlwifi/mvm/tx.c:1369 iwl_mvm_rx_tx_cmd+0x35a/0x860 [iwlmvm] [iwlwifi]
Summary: [abrt] iwl_pcie_rx_handle: WARNING: CPU: 0 PID: 538 at drivers/net/wireless/i...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:fa5388fcda48abd0bf6ca756807...
: 1595863 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 08:37 UTC by Tomáš Vlček
Modified: 2018-10-25 07:56 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-25 07:56:53 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (78.61 KB, text/plain)
2018-05-12 08:38 UTC, Tomáš Vlček
no flags Details

Description Tomáš Vlček 2018-05-12 08:37:56 UTC
Description of problem:
1. Setup a wireless hotspot on a laptop.
2. Connect to the hotspot with an android device (cell phone in my case)
3. krenel-core crashed after my phone obtained a IP adress.

Additional info:
reporter:       libreport-2.9.5
WARNING: CPU: 0 PID: 538 at drivers/net/wireless/intel/iwlwifi/mvm/tx.c:1369 iwl_mvm_rx_tx_cmd+0x35a/0x860 [iwlmvm]
Modules linked in: nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp fuse rfcomm xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ccm devlink ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables bnep sunrpc vfat fat intel_rapl
 x86_pkg_temp_thermal intel_powerclamp coretemp uvcvideo kvm videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common arc4 videodev irqbypass crct10dif_pclmul media crc32_pclmul ghash_clmulni_intel iwlmvm intel_cstate mac80211 intel_uncore snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic hp_wmi iTCO_wdt sparse_keymap iTCO_vendor_support wmi_bmof intel_rapl_perf snd_hda_intel snd_hda_codec iwlwifi btusb btrtl btbcm btintel bluetooth cfg80211 snd_hda_core snd_hwdep rtsx_pci_ms ecdh_generic memstick hp_accel snd_seq rfkill snd_seq_device snd_pcm joydev snd_timer lis3lv02d tpm_infineon mei_me snd soundcore tpm_tis tpm_tis_core tpm mei lpc_ich input_polldev wmi shpchp hp_wireless i915 i2c_algo_bit rtsx_pci_sdmmc drm_kms_helper mmc_core drm crc32c_intel r8169 rtsx_pci
 serio_raw mii video
CPU: 0 PID: 538 Comm: irq/50-iwlwifi Not tainted 4.16.7-300.fc28.x86_64 #1
Hardware name: Hewlett-Packard HP ProBook 430 G2/2246, BIOS M73 Ver. 01.42 09/26/2016
RIP: 0010:iwl_mvm_rx_tx_cmd+0x35a/0x860 [iwlmvm]
RSP: 0018:ffffa9ac410bbd40 EFLAGS: 00010246
RAX: ffff8c0425de1b01 RBX: ffff8c0468382000 RCX: 000000000000011e
RDX: 000000000000011d RSI: ffff8c0490426440 RDI: ffffe13187977800
RBP: ffff8c0476b71528 R08: 0000000000026440 R09: ffffffffc09c7dbc
R10: ffffffffa8459d80 R11: ffff8c049041f944 R12: 0000000000000088
R13: 0000000000000000 R14: ffff8c0481dcd830 R15: ffff8c0481dcd800
FS:  0000000000000000(0000) GS:ffff8c0490400000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f2e6a970000 CR3: 000000015e20a004 CR4: 00000000003606f0
Call Trace:
 iwl_pcie_rx_handle+0x225/0x890 [iwlwifi]
 iwl_pcie_irq_handler+0x5c8/0xa30 [iwlwifi]
 ? irq_finalize_oneshot.part.39+0xf0/0xf0
 ? irq_thread_check_affinity+0xe0/0xe0
 irq_thread_fn+0x1f/0x50
 ? irq_finalize_oneshot.part.39+0xf0/0xf0
 irq_thread+0x146/0x1a0
 ? irq_forced_thread_fn+0x60/0x60
 kthread+0x112/0x130
 ? kthread_create_worker_on_cpu+0x70/0x70
 ? do_syscall_64+0x74/0x180
 ? SyS_exit_group+0x10/0x10
 ret_from_fork+0x35/0x40
Code: 00 41 89 c4 89 44 24 10 8d 40 ff 66 89 44 24 0e 48 8d 44 24 28 49 39 c7 0f 84 6f 02 00 00 40 88 6c 24 1f 4c 89 f5 e9 e3 00 00 00 <0f> 0b 41 81 4f 28 00 01 00 00 45 31 ed 48 8b 45 10 48 8b b0 c0 

Potential duplicate: bug 1563416

Comment 1 Tomáš Vlček 2018-05-12 08:38:12 UTC
Created attachment 1435314 [details]
File: dmesg

Comment 2 ingli 2018-06-27 15:29:49 UTC
*** Bug 1595863 has been marked as a duplicate of this bug. ***

Comment 3 archura 2018-07-15 15:00:41 UTC
Description of problem:
I created a wifi hotspot. Strangely, it did not work formerly and did not give error. Now it caused an error but it is working.

Version-Release number of selected component:
kernel-core-4.17.5-200.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        BOOT_IMAGE=/vmlinuz-4.17.5-200.fc28.x86_64 root=UUID=b6be0a37-fdc2-4c09-a7dc-d72ef62a3053 ro rootflags=subvol=root resume=UUID=38d5aac4-2dcb-40d6-ad4e-ec1e67351beb rhgb quiet loglevel=0 vt.global_cursor_default=0 scsi_mod.use_blk_mq=1 LANG=en_GB.UTF-8
crash_function: iwl_pcie_rx_handle
kernel:         4.17.5-200.fc28.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 2 PID: 662 at drivers/net/wireless/intel/iwlwifi/mvm/tx.c:1377 iwl_mvm_rx_tx_cmd+0x35a/0x860 [iwlmvm]
Modules linked in: nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT cmac ccm fuse rfcomm xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun devlink ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables bnep sunrpc vfat fat arc4 intel_rapl
 x86_pkg_temp_thermal intel_powerclamp coretemp iwlmvm kvm_intel mac80211 btusb kvm btrtl uvcvideo btbcm snd_soc_rt5640 irqbypass snd_hda_codec_hdmi snd_soc_rl6231 msi_wmi iTCO_wdt videobuf2_vmalloc videobuf2_memops snd_hda_codec_realtek btintel snd_hda_codec_generic snd_hda_intel snd_hda_codec snd_soc_core iwlwifi snd_hda_core snd_compress snd_pcm_dmaengine crct10dif_pclmul crc32_pclmul ac97_bus ghash_clmulni_intel gpio_ich videobuf2_v4l2 snd_hwdep sparse_keymap iTCO_vendor_support bluetooth snd_seq videobuf2_common intel_cstate intel_uncore videodev rtsx_usb_ms snd_seq_device memstick media ecdh_generic intel_rapl_perf cfg80211 snd_pcm snd_timer rfkill snd joydev mei_me soundcore i2c_i801 mei acpi_pad shpchp lpc_ich ie31200_edac btrfs libcrc32c xor zstd_decompress zstd_compress xxhash
 raid6_pq i915 nouveau ttm i2c_algo_bit drm_kms_helper rtsx_usb_sdmmc mmc_core mxm_wmi drm crc32c_intel serio_raw alx mdio rtsx_usb video wmi
CPU: 2 PID: 662 Comm: irq/35-iwlwifi Not tainted 4.17.5-200.fc28.x86_64 #1
Hardware name: Micro-Star International Co., Ltd. GE72 2QC/MS-1792, BIOS E1792IMS.116 11/17/2015
RIP: 0010:iwl_mvm_rx_tx_cmd+0x35a/0x860 [iwlmvm]
RSP: 0018:ffff9dde01fafd40 EFLAGS: 00010246
RAX: ffff909109c77301 RBX: ffff908fbbaf3000 RCX: 0000000180150008
RDX: 0000000180150009 RSI: ffffed314d271d80 RDI: 0000000040000000
RBP: ffff9090fb3f5528 R08: ffff909109c77e00 R09: 0000000180150008
R10: ffffffffa7480120 R11: 00000069d67bbe00 R12: 0000000000000088
R13: 0000000000000000 R14: ffff90910bbff930 R15: ffff90910bbff900
FS:  0000000000000000(0000) GS:ffff90911f280000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f361fa89000 CR3: 000000027820a001 CR4: 00000000001606e0
Call Trace:
 iwl_pcie_rx_handle+0x225/0x890 [iwlwifi]
 iwl_pcie_irq_handler+0x5c8/0xa30 [iwlwifi]
 ? irq_finalize_oneshot.part.41+0xf0/0xf0
 ? irq_thread_check_affinity+0xe0/0xe0
 irq_thread_fn+0x1f/0x50
 ? irq_finalize_oneshot.part.41+0xf0/0xf0
 irq_thread+0x146/0x1a0
 ? irq_forced_thread_fn+0x60/0x60
 kthread+0x112/0x130
 ? kthread_create_worker_on_cpu+0x70/0x70
 ret_from_fork+0x35/0x40
Code: 00 41 89 c4 89 44 24 10 8d 40 ff 66 89 44 24 0e 48 8d 44 24 28 49 39 c7 0f 84 6f 02 00 00 40 88 6c 24 1f 4c 89 f5 e9 e3 00 00 00 <0f> 0b 41 81 4f 28 00 01 00 00 45 31 ed 48 8b 45 10 48 8b b0 c0

Comment 4 Laura Abbott 2018-10-01 21:17:03 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 5 Tomáš Vlček 2018-10-24 20:44:52 UTC
(In reply to Laura Abbott from comment #4)
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 28 kernel bugs.
>  
> Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
>  
> If you have moved on to Fedora 29, and are still experiencing this issue,
> please change the version to Fedora 29.
>  
> If you experience different issues, please open a new bug report for those.

Kernel 4.18.14-200.fc28 works fine for me. Thanks for the fix.

Comment 6 Laura Abbott 2018-10-25 07:56:53 UTC
Thanks for letting us know


Note You need to log in before you can comment on or make changes to this bug.