Bug 1577494 - All quantum chemistry packages are broken under Fedora 28 (openMX included)
Summary: All quantum chemistry packages are broken under Fedora 28 (openMX included)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: openmx
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: marcindulak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 12:30 UTC by Henrique C. S. Junior
Modified: 2018-06-08 20:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-08 20:01:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Henrique C. S. Junior 2018-05-12 12:30:22 UTC
It is impossible to install openMX in Fedora 28 using DNF. Is this a mass rebuild problem?

# dnf install openmx*
Erro: 
 Problema 1: conflicting requests
  - nothing provides libgfortran.so.4()(64bit) needed by openmx-mpich-3.8.1-12.fc27.x86_64
 Problema 2: conflicting requests
- nothing provides libgfortran.so.4()(64bit) needed by openmx-openmpi-3.8.1-12.fc27.x86_64


dnf whatprovides */libgfortran.so.4
(returns nothing)

But we do have:
dnf whatprovides /libgfortran.so.*

libgfortran-8.0.1-0.20.fc28.x86_64 : Fortran runtime
Repo        : fedora
Resultado a partir de:
Nome de arquivo    : /usr/lib64/libgfortran.so.5
Resultado a partir de:
Nome de arquivo    : /usr/lib64/libgfortran.so.5.0.0

Comment 2 marcindulak 2018-06-08 20:01:43 UTC
I've orphaned openmx due to bug #1583381


Note You need to log in before you can comment on or make changes to this bug.