Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577512 - gnome terminal hangs after switch to another application
Summary: gnome terminal hangs after switch to another application
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte
Version: 6.9
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 16:13 UTC by Alain D D Williams
Modified: 2019-07-03 13:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-03 12:27:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alain D D Williams 2018-05-12 16:13:15 UTC
Description of problem:

A gnome terminal session will hang after a switch to something else (eg evince - and do a page-up) and then back to gnome terminal. Typing characters does nothing, but scroll the mouse (or double-click a word) and it reawakens and the typed characters are sent to the application.

It does seem to depend on the application being run under gnome terminal; it happens with mutt, but not vim.

Attaching the application (ie mutt) with strace some how ''fixed'' the issue; then I ran strace under xterm (ie not gnome terminal) and the 'protective' effect of strace did not happen.

I also saw this affect bash (when I suspended mutt with ^z).

If I ran mutt under xterm I do not see this behaviour.

Gnome terminal 2.31.3

x86_64 fully up to date - CentOS

This first appeared after I ran an update that installed the components below and I then rebooted due to the new kernel. Do however that a new version of VTE was installed, I suspect that this is the change that made this problem.

May 11 08:51:09 Updated: kernel-firmware-2.6.32-696.28.1.el6.noarch
May 11 08:51:17 Installed: kernel-2.6.32-696.28.1.el6.x86_64
May 11 08:51:21 Updated: tzdata-2018e-3.el6.noarch
May 11 08:51:23 Updated: kernel-headers-2.6.32-696.28.1.el6.x86_64
May 11 08:53:04 Installed: kernel-devel-2.6.32-696.28.1.el6.x86_64
May 11 08:53:06 Updated: perf-2.6.32-696.28.1.el6.x86_64
May 11 08:53:20 Updated: kernel-doc-2.6.32-696.28.1.el6.noarch
May 11 08:53:22 Updated: tzdata-java-2018e-3.el6.noarch
May 11 08:53:23 Updated: kernel-abi-whitelists-2.6.32-696.28.1.el6.noarch
May 11 08:53:25 Updated: vte-0.25.1-10.el6_9.x86_64





How reproducible:

Very

Steps to Reproduce:
1.

Run mutt under gnome terminal

2.

Switch to another virtual desktop (Ctrl-Shift-arrow-key) where evince is running.

3.

Page up/down in the PDF

4.

Switch back to mutt

5.

Press keys that mutt should react to, eg up-arrow and nothing happens.

Comment 2 Debarshi Ray 2018-05-16 16:05:55 UTC
Sounds similar to bug 1546615

Comment 4 Alain D D Williams 2019-07-03 12:59:51 UTC
Why is this marked WONTFIX ? Is it because RHEL 6 has not got long to live ?

I cannot see bug 1546615.


Note You need to log in before you can comment on or make changes to this bug.