Bug 1577548 - Can't system-upgrade from releasever 28 to 29
Summary: Can't system-upgrade from releasever 28 to 29
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 23:56 UTC by Matt Daveson
Modified: 2018-11-27 19:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-27 19:46:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt Daveson 2018-05-12 23:56:52 UTC
[root@localhost ~]# dnf --refresh upgrade
Failed to set locale, defaulting to C
Last metadata expiration check: 0:00:00 ago on Sun May 12 04:52:12 2018.
Dependencies resolved.
Nothing to do.
Complete!

[root@localhost ~]# exit
logout

[user@localhost Documents]$ sudo dnf system-upgrade download --refresh --releasever=29
Failed to set locale, defaulting to C
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 29 - x86_64 - Updates                                                                                                  4.6 MB/s |  61 MB     00:13    
Fedora 29 - x86_64                                                                                                            5.8 MB/s |  61 MB     00:10    
RPM Fusion for Fedora 29 - Nonfree - NVIDIA Driver                                                                             24 kB/s | 7.0 kB     00:00    
Failed to synchronize cache for repo 'rpmfusion-free-updates', disabling.
Failed to synchronize cache for repo 'rpmfusion-free', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree-updates', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree', disabling.
Last metadata expiration check: 0:00:00 ago on Sun May 12 04:52:45 2018.
Error: 
 Problem 1: package rpmfusion-free-release-28-1.noarch requires system-release(28), but none of the providers can be installed
  - fedora-release-28-1.noarch does not belong to a distupgrade repository
  - problem with installed package rpmfusion-free-release-28-1.noarch
 Problem 2: package fedora-release-28-1.noarch requires fedora-repos(28) >= 1, but none of the providers can be installed
  - package rpmfusion-nonfree-release-28-1.noarch requires system-release(28), but none of the providers can be installed
  - fedora-repos-28-2.noarch does not belong to a distupgrade repository
  - problem with installed package rpmfusion-nonfree-release-28-1.noarch

Comment 1 Jaroslav Mracek 2018-10-01 13:01:16 UTC
Please can you try upstream dnf from our copr repository if the problem is still reproducible (dnf copr enable rpmsoftwaremanagement/dnf-nightly)? Thanks for additional information.

Comment 2 Jaroslav Mracek 2018-11-27 19:46:43 UTC
Please if the problem can be reproduce with dnf-4.0.4 or later version, please don't hesitate to reopen the bug report with additional information.


Note You need to log in before you can comment on or make changes to this bug.