Bug 157760 - No Match for USB Device HP3840
No Match for USB Device HP3840
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: foomatic (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 161686 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-14 13:09 EDT by rich
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 08:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rich 2005-05-14 13:09:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
Receive the following while configuring a printer.

No match for USB device:
  mfr "HP"
  model "Deskjet 3840"
  desc "3845"
  cmdset "LDL,DYN"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


The actual model of my usb printer is 3847.  Works fine in WinXP on the same system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Using system-config-printer
2.Imported PPD HP-DeskJet_3840-hpijs.ppd 
3.Added Printer
4.Rescan device produced error messages indicated.
5.Print of test page fails  

Actual Results:  No print and error message indicated.

Expected Results:  No error message and print test page produced.

Additional info:
Comment 1 Tim Waugh 2005-05-16 10:37:13 EDT
The message you quote is harmless, and just means that the printer model can't
be automatically selected from the list.

It is not related to the more serious problem of not being able to print.

So let's focus on that for a bit: how exactly does the print fail?  Is there
anything in /var/log/cups/error_log that indicates what the failure might be?
Comment 2 rich 2005-05-16 13:14:43 EDT
Yesterday (5/15) I tried adding the printer using the CUPS web interface. I.E. ...

http://localhoast:631
<Add Printer>

It recognized the printer and I was able to print a test page.  After that it
showed up as a queue in system-config-printer and I was able to print a test
page when the queue entry was selected.  I am now also able to print the test
page from the printer I originally added using system-config-printer!

I tried many things to resolve this problem so I can't really identify why
things are now working.  I do know that success started after configuring the
printer using the CUPS web interface.

I did look at the error_log file and there were some suspcious messages...

W [14/May/2005:11:01:32 -0400] LoadDevices: Backend did not respond within 30
seconds!
W [14/May/2005:11:02:37 -0400] LoadDevices: Backend did not respond within 30
seconds!
I [14/May/2005:11:03:07 -0400] LoadPPDs: Read "/etc/cups/ppds.dat", 4227 PPDs...
I [14/May/2005:11:03:08 -0400] LoadPPDs: No new or changed PPDs...
I [14/May/2005:11:03:08 -0400] Full reload complete.
I [14/May/2005:11:03:09 -0400] Started filter /usr/lib64/cups/filter/pstops (PID
6059) for job 8.
I [14/May/2005:11:03:09 -0400] Started filter
/usr/lib64/cups/filter/foomatic-rip (PID 6060) for job 8.
I [14/May/2005:11:03:09 -0400] Started backend /usr/lib64/cups/backend/hal (PID
6061) for job 8.
E [14/May/2005:11:03:09 -0400] PID 5938 stopped with status 0!
I [14/May/2005:11:03:09 -0400] Hint: Try setting the LogLevel to "debug" to find
out more.E [14/May/2005:11:03:09 -0400] PID 5939 stopped with status 0!
I [14/May/2005:11:03:09 -0400] Hint: Try setting the LogLevel to "debug" to find
out more

Also...

E [14/May/2005:11:10:48 -0400] PID 2545 stopped with status 1!
I [14/May/2005:11:10:48 -0400] Hint: Try setting the LogLevel to "debug" to find
out more.E [14/May/2005:11:10:48 -0400] [Job 8] Unable to open HAL device
"hal:///org/freedesktop/Hal/devices/usb_usb_device_3f0_7504_100_-1_TH51J1912S040R_0"
E [14/May/2005:11:10:53 -0400] PID 2544 stopped with status 9!
I [14/May/2005:11:10:53 -0400] Hint: Try setting the LogLevel to "debug" to find
out more.

There were many other messages in the log and I did turn on "Debug" in
/etc/cups/cupsd.conf for a while.

So, I really don't know what to say about it at this point. Things are now
working!  Let me know if you want to see the whole log.
Comment 3 Tim Waugh 2005-05-19 08:25:29 EDT
Okay, closing.  I've added the autodetection information from your initial report.
Comment 4 Tim Waugh 2005-06-27 07:48:20 EDT
*** Bug 161686 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.