Bug 1577676 - [RFE] Generic class cannot be deleted or need a way in UI to remove service association from Generic class
Summary: [RFE] Generic class cannot be deleted or need a way in UI to remove service a...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Harpreet Kataria
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 22:34 UTC by Shveta
Modified: 2019-12-18 14:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 14:35:11 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
remove option disabled (104.38 KB, image/png)
2018-05-13 22:34 UTC, Shveta
no flags Details

Description Shveta 2018-05-13 22:34:25 UTC
Created attachment 1435958 [details]
remove option disabled

Description of problem:


Version-Release number of selected component (if applicable):
5.9.2.4.20180501195858_35dc609

How reproducible:


Steps to Reproduce:
1. Created a Generic class .(Automation- Automate - Generic Object)
2. "Remove the generic object class from inventory "is enabled.
3.  Through rails console , create a generic object instance and then associate it with a service (https://bugzilla.redhat.com/show_bug.cgi?id=1577395)
4. Now there is no way in UI to delete the generic class since we cannot remove the service association.

Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.