Bug 157865 - "msg" function name in libaudit conflicts with symbols in some apps
"msg" function name in libaudit conflicts with symbols in some apps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 12:07 EDT by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 18:08:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-05-16 12:07:53 EDT
I was getting a coredump out of ipop3d (which I know isn't supported anymore, 
but the problem I was seeing could just as easily occur in another, currently 
supported app), because there's a pointer variable in ipop3d called "msg" and 
the linker was trying to call that variable as a function from inside libaudit 
rather than calling the "msg" function in the library.  I think the function 
should be renamed to something more specific to libaudit and hence less likely 
to conflict with variable names in applications.
Comment 1 Steve Grubb 2005-05-17 18:08:43 EDT
Thanks for reporting the issue. I've fixed it in 0.8.1 - which will be in
rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.