Bug 15789 - partitioning/formatting goes wrong
Summary: partitioning/formatting goes wrong
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-09 08:38 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 08:38:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-09 08:38:09 UTC
Hello,

I thing the following problem has more to do with mke2fs, but I couldn't 
select that one from the components...

Yesterday I installed Redhat6.2. After the installation I added a new 
partition (logical one in the extended partition) and tried to format it 
with mke2fs.

First time mke2fs reported me that there was a bad superblock on the 
partition. After a reboot formatting went OK.

I also made another new partition, and formatted with mke2fs. It seemed to 
go OK, but after formatting I discovered with "df -h" that the partition 
was only 30 MB large, although with fdisk I made the partition 2 GB large. 
This was also a logical partition in the extended partition. Also here: 
after reboot, formatting went OK.

What is the problem?

Regards,
Jurgen Goedbloed.

Comment 1 Cristian Gafton 2000-09-06 14:48:52 UTC
This is happening because the kernel hold busy the device you are modifying the
partition table on. You will need to reboot after changing the partition
information to force teh kernel to re-read the partitioning table.

Pay attention to the Device busy messages you get when writing new partitioning
ifnormation to disk.



Note You need to log in before you can comment on or make changes to this bug.