Bug 157912 - Installer crash during readHeaders of harddrive.py
Installer crash during readHeaders of harddrive.py
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 21:00 EDT by Chris Rainey
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 15:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt from floppy during install/crash (73.53 KB, text/plain)
2005-05-16 21:03 EDT, Chris Rainey
no flags Details

  None (edit)
Description Chris Rainey 2005-05-16 21:00:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
After creating an ISO image from my local directory tree of fc4/rawhide and using the most recent boot.iso from said tree, I can not move past the "Reading Packages" stage after partitioning is done.

Version-Release number of selected component (if applicable):
fc4-test-3/rawhide

How reproducible:
Always

Steps to Reproduce:
1.  Boot boot.iso
2.  step through graphical installer
3.  click next after completing 'create root password' stage
  

Actual Results:  Crash with dump of debug/traceback to floppy disk.

Expected Results:  display installer progress screen

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 172, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 240, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 158, in readPackages
    hdrlist = method.readHeaders()
  File "/usr/lib/anaconda/harddrive.py", line 155, in readHeaders
    if not self.discImages.has_key(h[1000002]):
TypeError: list objects are unhashable

Local variables in innermost frame:
h: ant-apache-bcel-0:1.6.2-3jpp_6fc.i386
self: <harddrive.HardDriveInstallMethod instance at 0xb79421ac>
hl: <hdrlist.HeaderListFromFile instance at 0xb7a4b70c>
missing_images: []
Comment 1 Chris Rainey 2005-05-16 21:03:20 EDT
Created attachment 114453 [details]
anacdump.txt from floppy during install/crash

In case the full traceback/crash dump might be useful.
Comment 2 Chris Rainey 2005-05-16 21:07:14 EDT
Just wanted to note that I can successfully install fro this same tree using '
ftp ' install from over my local LAN.  I believe the ' tree ' is good.

I wish I could figure-out why you require an ISO for a local-drive install(!?!?).
Comment 3 Chris Lumens 2005-06-24 15:16:35 EDT
Sorry, I'm a little confused.  What's your installation method again?
Comment 4 Chris Rainey 2005-06-26 14:39:46 EDT
Sorry ... I keep an RSYNC'd tree of RAWHIDE on my local workstation.  I was attempting to install from this 
tree as a CD-ISO image made using the following script:  ftp://people.redhat.com/ckloiber/FedoraSync.sh

Anaconda does not seem to be able to install from a 'local tree' ... only from local or network CD-ISO 
images.  Why is this?  I usually have to copy my 'local tree' to another FTP or NFS server on my network in 
order to be able to install over the LAN.  This can be annoying when I already have the install tree available 
on a second drive in my local workstation.
Comment 5 Chris Lumens 2006-06-02 15:04:13 EDT
This code has all been removed since we are now using yum as the backend, so
your bug should be gone now too.

Note You need to log in before you can comment on or make changes to this bug.