Bug 157916 - kernel panics on shutdown in umount
kernel panics on shutdown in umount
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks: 170417
  Show dependency treegraph
 
Reported: 2005-05-16 22:26 EDT by AIST-CVS support team
Modified: 2010-10-21 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen dump of kernel panic (1.07 KB, text/plain)
2005-05-16 22:28 EDT, AIST-CVS support team
no flags Details

  None (edit)
Description AIST-CVS support team 2005-05-16 22:26:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7) Gecko/20050309 Firefox/0.9.3

Description of problem:
kernel panics when shutting down the system in umount process.

Please see screen dump in the attachment.

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.0.2.EL

How reproducible:
Sometimes

Steps to Reproduce:
1.boot the system
2.run the system for several days
3.shutdown the system
  

Actual Results:  See attachment.

Expected Results:  The system will shutdown normally

Additional info:

We have two systems running on the same hardware, say main machine & backup
machine.

We experienced this panic several times only on main machine. On the backup
machine it won't occur.

Also, if the uptime is relatively short(few hours), it won't occur.

Major difference of these two machines are as below.

System activity of main machine is relatively high.
Main machine is NFS server and backup machine is NFS client.
Main machine uses loopback mounting, backup machine doesn't.

The bug #129477 is simillar to this problem, but the call trace differs.
At least two times of our experience showed the same call trace.
Comment 1 AIST-CVS support team 2005-05-16 22:28:10 EDT
Created attachment 114454 [details]
screen dump of kernel panic
Comment 2 AIST-CVS support team 2005-05-25 23:01:07 EDT
We also have experienced on the kernel-2.4.21-27.0.4.EL.

screen dump of kernel is as follows.

CPU:    0
EIP:    0060:[<f888f496>]    Not tainted
EFLAGS: 00010282

EIP is at ext3_put_super [ext3] 0x166 (2.4.21-27.0.4.EL/i686)
eax: 00000056   ebx: f786b750   ecx: 00000001   edx: 00000001
esi: f786b5ec   edi: f786b400   ebp: 00000808   esp: f7f6bf50
ds: 0068   es: 0068   ss: 0068
Process umount (pid: 24967, stackpage=f7f6b000)
Stack: f8895f80 f8897587 f889757f 000001ce f8897564 f786b400 f786b444 f88998e0
       f888f330 c015b37b f786b400 00000000 f7f6bf98 0804def8 bfffd0e8 c016f9ff
       f786b400 00000001 c359a900 c39b7440 128f9d6e 00000008 00000001 00000009
Call Trace:   [<f8895f80>] .rodata.str1.4 [ext3] 0xc54 (0xf7f6bf50)
[<f8897587>] .rodata.str1.1 [ext3] 0x75f (0xf7f6bf54)
[<f889757f>] .rodata.str1.1 [ext3] 0x757 (0xf7f6bf58)
[<f8897564>] .rodata.str1.1 [ext3] 0x73c (0xf7f6bf60)
[<f88998e0>] ext3_sops [ext3] 0x0 (0xf7f6bf6c)
[<f888f330>] ext3_put_super [ext3] 0x0 (0xf7f6bf70)
[<c015b37b>] kill_super [kernel] 0xfb (0xf7f6bf74)
[<c016f9ff>] sys_umount [kernel] 0x3f (0xf7f6bf8c)

Code: 0f 0b ce 01 7f 75 89 f8 eb 80 89 74 24 04 89 3c 24 e8 f4 fd

Kernel panic: Fatal exception
Comment 3 AIST-CVS support team 2005-06-22 01:00:05 EDT
We also have experienced on the kernel-2.4.21-32.EL

screen dump of kernel is as follows.

CPU:    0
EIP:    0060:[<f8890496>]    Not tainted
EFLAGS: 00010282

EIP is at ext3_put_super [ext3] 0x166 (2.4.21-32.EL/i686)
eax: 00000056   ebx: c341f750   ecx: 00000001   edx: 00000001
esi: c341f4ec   edi: c341f400   ebp: 00000808   esp: c8a57f50
ds: 0068   es: 0068   ss: 0068
Process umount (pid: 23895, stackpage=c8a57000)
Stack: f8896f90 f8898597 f889858f 000001ce f8898574 c341f400 c341f444 f889a8e0
       f8890330 c015b6bb c341f400 00000000 c8a57f98 0004def8 bfffcb78 c016ff6f
       c341f400 00000001 c37fcd00 c39b7440 128f9d6e 00000008 00000001 00000009
Call Trace:   [<f8896f90>] .rodata.str1.4 [ext3] 0xc54 (0xc8a57f50)
[<f8898597>] .rodata.str1.1 [ext3] 0x75f (0xc8a57f54)
[<f889858f>] .rodata.str1.1 [ext3] 0x757 (0xc8a57f58)
[<f8898574>] .rodata.str1.1 [ext3] 0x73c (0xc8a57f60)
[<f889a8e0>] ext3_sops [ext3] 0x0 (0xc8a57f6c)
[<f8890330>] ext3_put_super [ext3] 0x0 (0xc8a57f70)
[<c015b6bb>] kill_super [kernel] 0xfb (0xc8a57f74)
[<c016ff6f>] sys_umount [kernel] 0x3f (0xc8a57f8c)

Code: 0f 0b ce 01 8f 85 89 f8 eb 80 89 74 24 04 89 3c 24 e8 f4 fd

Kernel panic: Fatal exception
Comment 4 Miquel Mussons 2005-09-06 06:27:09 EDT
I also have experienced the same behavior but without shutdown of the 
equipment, only umounting a NFS partition. I cannot show the content of panic 
because was nothing in the monitor and I cannot find no file with panic 
information.

I have kernel-2.4.21-27.0.4.ELsmp.
Comment 5 Miquel Mussons 2005-09-06 06:28:03 EDT
I also have experienced the same behavior but without shutdown of the 
equipment, only umounting a NFS partition. I cannot show the content of panic 
because was nothing in the monitor and I cannot find no file with panic 
information.

I have kernel-2.4.21-27.0.4.ELsmp.
Comment 11 Ernie Petrides 2006-06-14 20:04:21 EDT
RHEL3 is now closed.  I also suggest trying out the latest RHEL3 U8 beta,
since a possibly related problem (bug 175216) was fixed early on in U8.
Comment 12 Prarit Bhargava 2007-09-12 13:56:58 EDT
AIST-CVS support team,

Is this still an issue when using RHEL3U8?

P.
Comment 13 RHEL Product and Program Management 2007-10-19 15:02:20 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.