Bug 157933 - httpd segfault on logrotate
Summary: httpd segfault on logrotate
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: apr (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-05-17 09:35 UTC by Joe Orton
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-622
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 15:37:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:622 qe-ready SHIPPED_LIVE httpd bug fix update 2005-10-05 04:00:00 UTC

Description Joe Orton 2005-05-17 09:35:58 UTC
+++ This bug was initially created as a clone of Bug #157832 +++

Description of problem:
httpd appears to have race problems in its cleanup handlers, in that it appears
those cleanup handlers can be run from multiple threads in the httpd process.

Version-Release number of selected component (if applicable):
httpd-2.0.46

How reproducible:
not sure

Steps to Reproduce:
N/A/
  
Actual results:
when receiving SIGHUP, httpd segfaults

Expected results:
server should restart

Additional info:
There were two parts to this bug: the segfaults are caused by missing error
checking in APR.

Comment 5 Red Hat Bugzilla 2005-10-05 15:37:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-622.html



Note You need to log in before you can comment on or make changes to this bug.