Bug 157972 - Crash with S3 Trio video card: KeyError: 'S3 Trio3D\nS3 Trio64 3D'
Crash with S3 Trio video card: KeyError: 'S3 Trio3D\nS3 Trio64 3D'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 163256 (view as bug list)
Depends On:
Blocks: 163907
  Show dependency treegraph
 
Reported: 2005-05-17 11:12 EDT by Dave Habben
Modified: 2014-03-16 22:53 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.159-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 09:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Habben 2005-05-17 11:12:20 EDT
Description of problem:
The anaconda installer crashes on machines with a S3 Trio video card. The error
logged is:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 827, in ?
    skipMouseProbe = skipmouseprobe)
  File "/usr/lib/python2.4/site-packages/rhpl/xserver.py", line 79, in probeHW
    videohw    = videocard.VideoCardInfo(skipDCCProbe=skipDCCProbe)
  File "/usr/lib/python2.4/site-packages/rhpl/videocard.py", line 512, in __in__
    if vc.getCardData().has_key("DRIVER"):
  File "/usr/lib/python2.4/site-packages/rhpl/videocard.py", line 175, in
getCardData
    return Video_cardsDBLookup(self.cardData["NAME"])
  File "/usr/lib/python2.4/site-packages/rhpl/videocard.py", line 34, in
VideoCardsDBLookup
    card = Video_cardslist[thecard]
KeyError: 'S3 Trio3D\nS3 Trio64 3D'
install exited abnormally


Version-Release number of selected component (if applicable):
Fedora 4, Test 3
Also reproducable on the rawhide boot.iso from May 17th 2005

How reproducible:
Every time


Steps to Reproduce:
1. Boot Fedora 4, test 3 from the CD-ROM
2. Begin the install process
3. As it goes to switch to graphical mode, it crashes with the above error
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2005-05-18 21:36:50 EDT
What does running ddcprobe provide?
Comment 2 Dave Habben 2005-05-19 09:00:29 EDT
ddcprobe results from Fedora Core 3 (Which installs correctly)
Videocard DDC probe results
Description:  S3 Incorporated. Trio3D
Memory (MB):  4

Monitor DDC probe results
ID: NEC65c6
Name: NEC LCD1550V
Horizontal Sync (kHZ): 31-60
Vertical Sync (HZ)  : 55-75
Width (mm): 300
Height(mm): 230

ddcprobe results from Fedora 4, test 3
Videocard DDC probe results
Description:  S3 Incorporated. Trio3D
Memory (MB):  4

Monitor DDC probe results
ID: NEC65c6
Name: NEC MultiSync LCD1550V
Horizontal Sync (kHZ): 31-60
Vertical Sync (HZ)  : 55-75
Width (mm): 300
Height(mm): 230
Comment 3 Jeremy Katz 2005-05-23 11:08:21 EDT
This really looks like something getting corrupted somewhere.  Did your media
pass mediacheck (http://rhlinux.redhat.com/anaconda/mediacheck.html)?
Comment 4 Dave Habben 2005-05-23 11:25:45 EDT
Yes, I tested all four discs and the result on all of them was: PASS
Comment 5 adam lau 2005-06-02 09:33:38 EDT
I have the exact same problem with fc4-test3 and the s3 trio video card. I'm 
using the dvd image and the media check passed. I received the same error 
message as Dave
Comment 6 Shane Brodie 2005-06-04 15:20:11 EDT
I have same problem on an IBM 300PL witrh integrated S3 video.  Installing from
CD-ROM fc4-test3.  As in the examples above, all media passed checks and I
received the identical error message string.

Videocard DDC probe results
Description:  S3 Incorporated. Trio3D
Memory (MB):  4

Monitor DDC probe results
ID: @@@0000
Name: O\uffff\uffff\uffff
Width (mm): 320
Height(mm): 240
Comment 7 Fritz 2005-06-09 12:57:23 EDT
I am experiencing the same problem on an IBM Netfinity 3000 with integrated S3 
video.  fc4-test3.  Media check also passes for CD installation media, I am 
booting from CD-1.
Comment 8 Dave Habben 2005-06-13 19:02:38 EDT
Same problem happens with the final release of fc4
Comment 9 Shadi T. Khasawneh 2005-06-14 08:39:34 EDT
I have the same problem with the final release of FC4. Mediacheck passes for all
CDs. Everything is working fine with FC3. It is an IBM 300PL machine.
======= ddcprobe from FC3 =======
Videocard DDC probe results
Description:  S3 Incorporated. Trio3D
Memory (MB):  4

Monitor DDC probe results
ID: @BM1996
Name: IBM P76
Horizontal Sync (kHZ): 30-94
Vertical Sync (HZ)  : 48-120
Width (mm): 330
Height(mm): 240
========================================
Comment 10 Brian 2005-06-14 19:33:13 EDT
I also have the same problem with an IBM 300GL with an integrated S3 Trio3D\nS3
Trio64 3D.  I'm using FC4.
Comment 11 Brian Thomson 2005-06-17 08:28:30 EDT
The problem here is in hwdata/Cards around line 1299.

There needs to be at least one blank line separating the "S3 Trio 3D" entry and
the "S3 Trio64 3D" entry.  Comment lines don't count.

This is required by the algorithm in videocard.py:VideoCardInfo.readCardsDB

The workaround I am using is to install with "linux headless".
Comment 12 Shadi T. Khasawneh 2005-06-17 09:30:39 EDT
I used "linux pci=off" - the installer will detect the video card as generic VESA.
Comment 13 Shadi T. Khasawneh 2005-06-17 10:39:34 EDT
The installation completed fine. After reboot GNOME started without any issues.
But the ethernet card was not detected. Moreover, running Kudzo to detect the
hardware gives the same error shown above!
In FC4 release notes:
"Some Sony VAIO® notebook systems may experience problems installing Fedora Core
from CD-ROM. If this happens, restart the installation process and add the
following option to the boot command line:
pci=off ide1=0x180,0x386"
I only used pci=off without the ide1 option (would that cause something?). 
Anyway, I would not recommend trying out this option (to solve this S3 problem)
unless confirmed by someone more experienced in this issue!
Comment 14 Chris Lumens 2005-06-17 10:42:41 EDT
Reassigning to hwdata on the basis of comment #11.
Comment 15 Bill Nottingham 2005-06-17 12:06:15 EDT
Added in CVS, will be in 0.159-1 (not very helpful for the installer, I realize.)
Comment 16 Patrick Demaerschalk 2005-07-15 04:24:27 EDT
I am also working on an IBM 300PL with integrated S3 video. When adding the
pci=off (with or without ide1=0x180,0x386) option the installation hangs after a
series of similar messages with the last one being:

[<c01012b1>] kernel_thread_helper+0x5/0x14

nothing happens after this and only remedy is turning off the box.
Comment 17 Bill Nottingham 2005-07-15 12:07:14 EDT
*** Bug 163256 has been marked as a duplicate of this bug. ***
Comment 18 Bisi Adedokun 2005-07-24 12:43:29 EDT
I have an IBM xSeries 240 server and installed FC4. Installation failed with 
similar messages as have been documented in previous postings. I used various 
options provided in the Release notes but none of them work. It asked me to 
manually select device drivers to load which I did. The installer says it 
cannot find any hard drive device to create partition. It then exit abnormally.

All the four discs passed verification. 

My system information reports that the machine has S3 Inc. Trio3D. The 
original error I got without using any of the boot options is KeyError: 'S3 
Trio3D\nS3 Trio64 3D' 
Comment 19 Bill Nottingham 2005-07-24 22:08:59 EDT
As stated before:
...
Added in CVS, will be in 0.159-1 (not very helpful for the installer, I realize.)
...
It's fixed in rawhide, the development tree.
Comment 20 Bisi Adedokun 2005-07-25 07:02:05 EDT
How can one get this fix to install? Or when will 0.159-1 be available? Is it 
possible to create installation discs from the development tree? Please advice.
Comment 21 Brian Thomson 2005-07-25 09:04:29 EDT
Until you have a release with this fix, you can avoid the problem by:

1. Invoke the installer with "linux headless".   This gives a text mode install.
2. When the system tries to reboot after, Kudzu will fail with the same 
message.   Edit the file /usr/share/hwdata/Cards inserting the blank line.
3. Rerun kudzu and continue.

Don't use pci=off, it skips configuring much more than your video.
Comment 22 Bill Nottingham 2005-07-25 09:57:31 EDT
(In reply to comment #20)
> How can one get this fix to install?

You'd have to create an update disk with the new Cards file.

> Or when will 0.159-1 be available?

It's already in the devel tree.
Comment 23 Bisi Adedokun 2005-07-27 10:54:36 EDT
After two attempts, I was finally able to get anaconda to install FC4 on IBM 
xSeries 240 server in text mode. I edited file /usr/share/hwdata/Cards 
inserting the blank line as suggested. I then ran kudzu, supplying the root 
password when prompted. However, kudzu kept coming back with Permission denied 
even though the root password I supplied is correct.

I have SELinux enabled (active) during installation. I do not know if this has 
anything to do with 'Permission denied' I'm getting.
Comment 24 John Lumby 2005-09-06 10:42:04 EDT
If like me your machine can't boot from CD-Rom, then you are probably using the
Generic Linux Boot Floppy.   In that case, I discovered that the way to get it
to invoke the anaconda with this "headless" option is to edit the kernel.opt on
the diskette and edit the keyword parm
--append=askmethod
to
--append=headless


mv /tmp/dkt/kernel.opt /tmp/dkt/kernel.opt.askmethod;
sed -e "s/askmethod/headless/g" /tmp/dkt/kernel.opt.askmethod >/tmp/dkt/kernel.opt
Comment 25 Roger K. Trussell 2005-11-14 02:02:46 EST
Hello everyone,

I too have a IBM PC 300PL.
I was able to get Fedora with the GUI to work on my system.
I had to piece together the various comments from Brian Thomson.
I used the "headless" option in the installer.
I did not use pci=off.
I edited the "cards" file.

I also downloaded a kernel update and I ran "rpm" on it.
I could not "yum" on that kernel update.
Please see Bill Nottingham's comment.

Also, I had to do some extra steps.
I just want to share these with the Fedora (Linux) community.
I had to run "system-config-display" from the /usr/share/system-config-display
directory. I could not simply re-run kudzu. "kudzu" failed to do anything useful
for me.

Also, since I followed Brian's comments and used the "headless" install option,
I did not have a system that would automatically boot into the GUI. I had to
edit one line in the "inittab". I had to change the line:
id:3:initdefault:

to: 
id:5:initdefault:

Once I did all that, I had GNOME working and everything.
I could login as root. I could add normal user accounts.
I have everything I want except support for the on-board Crystal Semiconductor
sound card and internal speaker.
I think I'll just get a cheap SoundBlaster card and speakers. 
I'll try telling the BIOS to ignore the on-board sound card.
I'll hunt and peck the BIOS setup for that option. lol...

Thanks everyone for all your helpful comments!!!!!!

Sincerely,
Roger

Note You need to log in before you can comment on or make changes to this bug.