Bug 157989 - GFS-kernel missing dependencies in /lib/modules
Summary: GFS-kernel missing dependencies in /lib/modules
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: GFS-kernel   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 17:25 UTC by Steve Huffman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 21:53:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Huffman 2005-05-17 17:25:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I installed FC4test3 clean with "everything". After completing the install I invoked up2date (command line) to bring it all current. up2date quits with failed dependencies in /lib/modules for GFS-kernel, dlm-kernel, gnbd-kernel, and cman-kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.up2date -u --nox
2.
3.
  

Actual Results:  up2date quits after not finding the right directory in /lib/modules

Expected Results:  new versions in /lib/modules should be available and the dependencies resolved

Additional info:

Comment 1 Jim Cornette 2005-05-18 03:33:00 UTC
Since this is holding up several packages, even in the src files which is
include the reference to 2.6.11-1.1288_FC4. I changed the information in the
spec files to reference 2.6.11-1.1312_FC4 instead and made it further through
the build.
Is there a way to get these modules to compile against the current running kernel?

Yum spews out the below errors.

 yum -y upgrade "*kernel"
Repository Extras already added, not adding again
Setting up Upgrade Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
Extras                    100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gnbd-kernel.i686 0:2.6.11.2-20050420.133124.FC4.19 set to be installed
---> Package dlm-kernel.i686 0:2.6.11.3-20050425.154843.FC4.16 set to be installed
---> Package GFS-kernel.i686 0:2.6.11.5-20050505.133825.FC4.6 set to be installed
---> Package cman-kernel.i686 0:2.6.11.3-20050425.154843.FC4.14 set to be installed
--> Running transaction check
--> Processing Dependency: /lib/modules/2.6.11-1.1288_FC4 for package: dlm-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.11-1.1288_FC4 for package: cman-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.11-1.1288_FC4 for package: gnbd-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.11-1.1288_FC4 for package: GFS-kernel
Importing Additional filelist information for dependency resolution
--> Finished Dependency Resolution
Error: Missing Dependency: /lib/modules/2.6.11-1.1288_FC4 is needed by package
dlm-kernel
Error: Missing Dependency: /lib/modules/2.6.11-1.1288_FC4 is needed by package
cman-kernel
Error: Missing Dependency: /lib/modules/2.6.11-1.1288_FC4 is needed by package
gnbd-kernel
Error: Missing Dependency: /lib/modules/2.6.11-1.1288_FC4 is needed by package
GFS-kernel

Comment 2 Jim Cornette 2005-05-18 10:43:43 UTC
Adding to CC:
Also a question regarding the eed for smp related elements when trying to
compile the src rpms. What, if anything, can be done to disregard smp elements
on a uniprocessor system?

Comment 3 Jim Cornette 2005-05-18 21:53:34 UTC
The dep problem has been resolved with GFS-kernel-2.6.11.6-20050517.141233.FC4.0


Comment 4 Chris Feist 2005-05-19 21:51:27 UTC
The best thing to do is edit the specfile and set buildsmp to '0'.


Note You need to log in before you can comment on or make changes to this bug.