Bug 158014 - [PATCH] xorg-x11 lacks support for i945G integrated graphics
[PATCH] xorg-x11 lacks support for i945G integrated graphics
Status: CLOSED DUPLICATE of bug 156964
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2005-05-17 16:15 EDT by wingc
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-17 17:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
[PATCH] support i945G as i915G in i810 driver, xorg-x11-6.8.2 (3.16 KB, patch)
2005-05-17 16:15 EDT, wingc
no flags Details | Diff

  None (edit)
Description wingc 2005-05-17 16:15:21 EDT
Description of problem:

The i810 driver in xorg-x11-6.8.2 lacks support for the i945G integrated
graphics controller found in recent Intel-based x86_64 capable PCs. The existing
i915G code in xorg-x11 seems to work with the i945G if the appropriate PCI IDs
are added.

Version-Release number of selected component (if applicable):

Tested most recent RHEL4 beta xorg-x11 RPM (xorg-x11-6.8.2-1.EL.5)

How reproducible:


Steps to Reproduce:
1. try to set up accelerated graphics (not the vesa driver) on a machine with
i945G chipset
Actual results:

i810 driver in xorg-x11-6.8.2 does not recognize the i945G chip

Expected results:

Additional info:

Due to the way the i810/i830 driver is structured, it is not possible to use the
ChipID override in xorg.conf to fake it into thinking the i945G is a i915.
However, when the driver is patched to handle the i945G as though it is a i915G,
everything works fine.

With the attached patch I rebuilt the i810 driver in xorg-x11-6.8.2 (using the
most recent RHEL4 beta), and everything is working for me including accelerated
OpenGL on a x86_64 machine. (pre-production Dell GX620, x86_64, i945G integrated
Comment 1 wingc 2005-05-17 16:15:21 EDT
Created attachment 114479 [details]
[PATCH] support i945G as i915G in i810 driver, xorg-x11-6.8.2
Comment 2 wingc 2005-05-17 16:46:04 EDT
See also the related bugs:
bug #157991 (intel-agp driver needed on x86_64)
bug #157995 (support i945G host bridge in intel-agp driver)
bug #157997 (i915 DRM kernel module needed on x86_64)
bug #158000 (support i945G integrated graphics in i915 DRM kernel module)
bug #158015 (support i945G integrated graphics in i915 DRI driver)
bug #158016 (disable debugging output to stderr in i915 DRI driver, x86_64)
Taken as a series, when these are all resolved it will be possible to get
working OpenGL acceleration in RHEL4 for the i945G integrated graphics chipset
on x86_64.
Comment 3 Mike A. Harris 2005-05-17 17:37:59 EDT

*** This bug has been marked as a duplicate of 156964 ***

Note You need to log in before you can comment on or make changes to this bug.