Bug 158016 - [PATCH] heavy debugging output to stderr left enabled in i915 DRI driver, on x86_64
[PATCH] heavy debugging output to stderr left enabled in i915 DRI driver, on ...
Status: CLOSED DUPLICATE of bug 181913
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks: 170416
  Show dependency treegraph
Reported: 2005-05-17 16:39 EDT by wingc
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-21 13:31:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
[PATCH] disable debugging output in i915 DRI driver on non-i386 (551 bytes, patch)
2005-05-17 16:39 EDT, wingc
no flags Details | Diff

  None (edit)
Description wingc 2005-05-17 16:39:30 EDT
Description of problem:

The i915 DRI driver in xorg-x11-6.8.2 includes some debugging code that is
always enabled on non-i386 platforms. This causes a huge amount of output to
spew into stderr when you try to run OpenGL software, and makes the driver too
slow to be usable.

If the debugging output is disabled, the i915 DRI driver runs fine on x86_64

Version-Release number of selected component (if applicable):

Tested most recent RHEL4 beta xorg-x11 RPM (xorg-x11-6.8.2-1.EL.5)

How reproducible:


Steps to Reproduce:
1. configure the i915 DRI driver on a x86_64 machine
2. run an OpenGL application
Actual results:

stderr is flooded with output and the driver runs very slowly

Expected results:

the OpenGL driver should run with adequate performance

Additional info:

If the debugging printf()s are removed from the DRI driver, then it seems to
work well on x86_64. Tested on my hardware (Dell pre-production GX620 with
integrated i945G graphics, x86_64).

I rebuilt the RHEL4 xorg-x11 package from the most recent beta
(xorg-x11-6.8.2-1.EL.5) using the attached patch, and everything worked well.

If this bug is resolved, along with the other bugs I entered today:

bug #157991 (intel-agp driver needed on x86_64)
bug #157995 (support i945G host bridge in intel-agp driver)
bug #157997 (i915 DRM kernel module needed on x86_64)
bug #158000 (support i945G integrated graphics in i915 DRM kernel module)
bug #158014 (support i945G integrated graphics in xorg-x11 i810 driver)
bug #158015 (support i945G integrated graphics in i915 DRI driver)

then OpenGL acceleration should work properly in RHEL4, on Intel x86_64 machines
with the i945G integrated graphics chipset. PC manufacturers will be introducing
such machines in the very near future.

Comment 1 wingc 2005-05-17 16:39:30 EDT
Created attachment 114482 [details]
[PATCH] disable debugging output in i915 DRI driver on non-i386
Comment 2 Mike A. Harris 2005-05-17 18:35:26 EDT
Red Hat Enterprise Linux customers are encouraged to log into the Red Hat
support website at http://www.redhat.com/support and file a support ticket,
or alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1
to speak directly with a support associate and escalate an issue.

While reporting an issue in bugzilla logs a problem so it can be tracked
for future OS releases, by using the official Red Hat Enterprise Linux
support mechanisms ensures that issues will be reviewed for consideration
in future updates of existing OS releases, and will receive higher
prioritization in engineering work queues.

Hope this helps, thanks in advance.
Comment 4 Mike A. Harris 2006-03-21 13:31:54 EST

*** This bug has been marked as a duplicate of 181913 ***

Note You need to log in before you can comment on or make changes to this bug.