Bug 158037 - Installer does not detect Synaptic TouchPad
Installer does not detect Synaptic TouchPad
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-17 20:03 EDT by Jason Salaz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 17:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Salaz 2005-05-17 20:03:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Anaconda does not detect the Touchpad.  I need to manually select it from the Mouse options list.  Even with the option selected, the driver does not load, and I am unable to use the Touchpad.

Note:  The Compaq R4000 series has an option to manually disable the TouchPad throguh pressing a button on top of it.  This may be teh cause of the issue also.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run anaconda in graphical node with 'linux nofb'
2. The system will not detect a mouse, adn ask for specifics.
3. Select Synaptic Touchpad, and continue install.

Actual Results:  No Synaptic touchpad support.

Expected Results:  Full support should have been implemented.

Additional info:
Comment 1 Paul Nasrat 2005-05-18 06:05:06 EDT
From the installer can you switch to tty2 and do:

cat /proc/bus/input/devices

python -c "import kudzu; print kudzu.probe(kudzu.CLASS_MOUSE, kudzu.BUS_UNSPEC,
kudzu.PROBE_ALL)"
Comment 2 Jason Salaz 2005-05-18 07:04:09 EDT
cat /proc/bus/input/devices yeilds:

I: Bus=0010 Vendor=001f Product 0001 Version=0100
N: Name="PC Speaker"
P: Phys="isa0061/input0"
H: Handlers=kbd event0
B: EV=40001
B: SND=6

I: Bus=0011 Vendor=0001 Product=0001 Version ab41
N: Name="AT Translated Set 2 Keyboard"
P: Phys=isa0060/serio0/input0
H: Handlers=kbd mouse0 event1
B: EV=120017
B: KEY=40000 4 2000078 3802078 f640d001 b2ffffdf ffeffffff ffffffff fffffffe
B: REL=140
B: MSC=10
B: LED=7

python -c "import kudzu; print kudzu.probe(kudzu.CLASS_MOUSE, kudzu.BUS_UNSPEC,
kudzu.PROBE_ALL)" yeilds:

[]
Comment 3 Paul Nasrat 2005-05-18 07:35:31 EDT
OK the touchpad isn't visible to the kernel hence we can't probe it or use it. 
Can you check in the bios or use the disable button to re-enable and retry.
Comment 4 Jason Salaz 2005-05-18 19:06:31 EDT
There is a manual button to shut it off, which provides no effect.  I have read
varying reports that this may actually be a 2.6.11 issue.  According to other
people thave have the Synaptics TouchPad, they have stayed with 2.6.10 since 11
seems to drop support.

There are no BIOS settings to manually turn the TouchPad off or on.  I went
ahead and rebooted with the Touchpad off with the same results as above.

Any other ideas?

Thanks for your help!

-Jason
Comment 5 Jeremy Katz 2005-05-18 21:15:37 EDT
Paul -- did you get this fixed with a kudzu change?
Comment 6 Paul Nasrat 2005-05-19 10:24:57 EDT
My synaptics laptop (HP Omnibook 6000) with 2.6.11-1.1315_FC4 picks up synaptics
fine. So there must be something slightly different about your setup. 

I'll try chase down similar hardware.  Are there any BIOS options about
mouse/legacy mode at all.
Comment 7 Jason Salaz 2005-05-19 19:31:00 EDT
There aren't any Legacy/mouse options that I can see in the BIOS.  That's what
it gets for being a Phoenix BIOS.  Award is better.  *smirk*

-Jason
Comment 8 Jason Salaz 2005-05-19 19:34:24 EDT
Also, I am running the default kernel with the isntaller (2.6.11-1.1286_FC4). 
How would I get my hands on the newer kernel, since it sounds that might be a
possible way to resolve this?

-Jason
Comment 9 Jason Salaz 2005-05-19 20:02:38 EDT
Running with 1319 kernel, and still no support.
Comment 10 Paul Nasrat 2005-05-19 22:21:51 EDT
I really can't replicate the synaptics issue you are having. Is the system dual
boot, or can you boot an older installer - say Fedora Core 3 (2.6.9 based) and
see if anything appears in /proc/bus/input/devices.  I am also uncertain how
this relates to the disable functionality of your laptop, so confirming the
touchpad working under linux would be a start.

Could you also try booting with psmouse.proto=imps and see if that has any
affect on touchpad and /proc/bus/input/devices.
Comment 11 Jason Salaz 2005-05-20 10:46:40 EDT
The laptop is Fedora Core only, so no dual boot issues there.  Fedora Core 3
does not allow for keyboard use (since it doesn't detect it), so that's why I
moved right to FC4-test3.

Also, what I mean by 'disable functionality' is that if you look physically
above the TouchPad, you can see a button with a symbol representing the TouchPad
that you can press to disable it. You don't have to go through the BIOS to
disable it.

Also, the Compaq R3000 series has this same concept.  There is a 'touchpad with
a dedicated on/off button', therefore not needing BIOS settings or whatnot.

2.6.10 does not find the keyboard, so 2.6.11 is required.
Comment 12 Paul Nasrat 2005-05-20 11:31:37 EDT
Please can you attach as individual uncompressed files dmesg from 2.6.10 (setup
a script in /etc/rc.local) and 2.6.11 please.

This is sounding more and more like a kernel issue.

Comment 13 Jason Salaz 2005-05-21 22:24:11 EDT
Could you guide me through that process please?  I'm still fairly new to scripts.

-Jason
Comment 14 Paul Nasrat 2005-05-25 09:36:02 EDT
Can you update to the latest rawhide kernel and attach the output of

dmesg

and a seperately 

find /sys/bus/serio/ -ls
Comment 15 Jeremy Katz 2005-09-21 17:12:34 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.

Note You need to log in before you can comment on or make changes to this bug.