Bug 158083 - fig2dev doesn't handle UTF-8 input
fig2dev doesn't handle UTF-8 input
Status: CLOSED DUPLICATE of bug 158082
Product: Fedora
Classification: Fedora
Component: transfig (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-18 10:54 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 13:49:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A doctored .fig file with utf-8 text. Text on the right in PDF should then read "Mecanismos de protección" (633 bytes, text/plain)
2005-05-18 10:54 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2005-05-18 10:54:47 EDT
Description of problem:
Creating a .fig file with UTF-8 accented characters with xfig fails. Fixing the
texts up by hand and giving the result to fig2dev gives weird output.

Version-Release number of selected component (if applicable):
transfig-3.2.4-11

How reproducible:
Always

Steps to Reproduce:
1. Create tst.fig file with UTF-8 text
2. fig2dev -L pdf tst.fig > tst.pdf
3.
  
Actual results:
Junk text in tst.pdf file


Expected results:
Correct text

Additional info:
Workaround if to use the C locale.
Comment 1 Horst H. von Brand 2005-05-18 10:54:47 EDT
Created attachment 114510 [details]
A doctored .fig file with utf-8 text. Text on the right in PDF should then read "Mecanismos de protección"
Comment 2 Ngo Than 2005-12-21 13:49:31 EST

*** This bug has been marked as a duplicate of 158082 ***

Note You need to log in before you can comment on or make changes to this bug.