This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 158104 - (IT_73498) Install with Radeon 7000 limits resolution to 800x600
Install with Radeon 7000 limits resolution to 800x600
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-18 14:04 EDT by Rod Macdonald
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 14:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.0.log and xorg.conf (8.03 KB, text/plain)
2005-05-18 14:04 EDT, Rod Macdonald
no flags Details
xorg.conf plus "noddc" (2.86 KB, text/plain)
2005-06-30 17:46 EDT, Rod Macdonald
no flags Details

  None (edit)
Description Rod Macdonald 2005-05-18 14:04:37 EDT
Description of problem:

When RHEL4 is installed on a Dell or Intel server which uses Radeon 7000 for 
video, the display will only provide 640x480 and 800x600 resolutions.  Various 
monitors were tried which indicates this is not an EDID problem.  

Version-Release number of selected component (if applicable):

4.0.1

Steps to Reproduce:
1. Install 
2. Check video modes.

Expected results:

The OS should make all resolutions supported by the monitor available.

Additional info:  The files, /etc/X11/xorg.conf and /var/log/Xorg.0.log are 
attached.  These are from an install on an Intel box with Xeon processor, 
motherboard: SE7525GP2
Comment 1 Rod Macdonald 2005-05-18 14:04:37 EDT
Created attachment 114526 [details]
xorg.0.log and xorg.conf
Comment 2 Rod Macdonald 2005-05-18 14:24:28 EDT
New information from jon chaplick [chaplick@ati.com]

I believe the bug is with RH4's ddcprobe utility failing thus causing only 
800x600 & 640x480 to be written to the xorg.conf file.


Comment 3 Mike A. Harris 2005-05-24 10:18:41 EDT
When filing partner issues, please contact the Red Hat partner contact
and have the issue filed in issue tracker so that it can be escalated
properly for review.  Also, when attaching files, please attach individual
uncompressed text files so they may be easily viewed directly in a web
browser.

Customer support requests for Red Hat Enterprise Linux support, please log
into the Red Hat Support web site at http://www.redhat.com/support and file
a support ticket to receive official Red Hat support for a given issue,
or alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1
to speak directly with a support associate and escalate an issue.

> Version-Release number of selected component (if applicable):
> 4.0.1

We ship xorg-x11 6.8.1 in RHEL4.  Not sure what 4.0.1 is the version of.
Please specify these details to the partner manager, along with this
bug ID when escalating the issue through issue tracker.

Thanks in advance.

Setting status to NEEDINFO, awaiting GSS escalation.
Comment 4 Larry Troan 2005-05-26 14:41:22 EDT
Issue tracker
https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=73498
opened and escalated to SEG with request to escalate to RHEL-kernel.
Comment 5 Mike A. Harris 2005-05-31 16:01:36 EDT
Please paste the output of the "ddcprobe" utility ran by root into a bug
update.

Are you using a KVM switch on the display, or any other equipment plugged
between the monitor cable and video card?

Also, when attaching files to bugzilla, please attach them as individual
uncompressed file attachments so they're readable in a web browser.

Thanks in advance.
Comment 6 Rod Macdonald 2005-05-31 17:33:49 EDT
The following is the output we get after running ddcprobe.

Videocard DDC probe results
Description: ATI Technologies Inc. R100
Memory (MB): 32

Monitor DDC probe results
ID: @HA0101
Width (mm): 10
Height(mm): 10

Please advise if this is what you were looking for.

There is no KVM switch being used on this particular machine and the monitor 
is connected directly to the graphics card (ATI Radeon 7000)

Regards, 
Comment 7 Wendy Hung 2005-06-03 13:07:24 EDT
Does the following work?

edit the /etc/X11/xorg.conf file. type the following line in the Monitor
section: Option "noddc"
Comment 8 Rod Macdonald 2005-06-30 17:46:15 EDT
Created attachment 116193 [details]
xorg.conf plus "noddc"
Comment 9 Rod Macdonald 2005-06-30 17:53:25 EDT
Results of the "noddc" test:

Option “noddc” added to the monitor section did not solve the resolution 
problem.  It caused NO changes in the available resolutions in RH4  (attached 
file: noddc_xorg.conf)

Changing the “HorizSync” and “VertRefresh” properties controls the allowable 
resolutions available.

By simply changing the “original_xorg.conf” files HorizSync and VertRefresh to 
the known range of the monitor I was using (Viewsonic Optiquest), I was then 
able to select all resolutions supported by the monitor.

Original xorg.conf
      HorizSync    31.5 - 37.9
      VertRefresh  50.0 - 70.0

Available resolutions: 640x480, 800x600

changing to:
      HorizSync   31.5 – 70.0
      VertRefresh  50   - 160
 
Available resolutions: 640x480, 800x600, 1024x768, 1152x864, 1280x1024
 
After a fresh RH4 installation, I had the following settings:

Monitor: Unknown Monitor
Graphics: ATI Radeon 7000
Available Resolutions: 640x480 & 800x600
 
Of course changing these parameters manually is not the prefeered approach.  
The OS needs the ablity to detect the attached monitor and set parameters 
appropriately.
Comment 10 Mike A. Harris 2005-07-08 01:56:25 EDT
(In reply to comment #6)
> The following is the output we get after running ddcprobe.
> 
> Videocard DDC probe results
> Description: ATI Technologies Inc. R100
> Memory (MB): 32
> 
> Monitor DDC probe results
> ID: @HA0101
> Width (mm): 10
> Height(mm): 10

This DDC data looks bogus.  It implies the monitor is 10mm x 10mm in size.


> Please advise if this is what you were looking for.
> 
> There is no KVM switch being used on this particular machine and the monitor 
> is connected directly to the graphics card (ATI Radeon 7000)

Yes, thanks.
Comment 11 Mike A. Harris 2005-07-08 02:09:37 EDT
Here is a sample of ddcprobe running on my workstation which has an
ATI FireGL 8800, with a Dell P991 monitor attached:

[root@laser html]# ddcprobe

Videocard DDC probe results
Description:  ATI Technologies Inc. R200
Memory (MB):  128

Monitor DDC probe results
ID: DEL5178
Name: Dell P991
Horizontal Sync (kHZ): 30-107
Vertical Sync (HZ)  : 48-120
Width (mm): 370
Height(mm): 270


As you can see here, the monitor provides the horizontal and vertical
sync ranges directly via VBE DDC probing, which is the mechanism used
by the ddcprobe utility (via LRMI).

If the ddcprobe utility is not receiving the proper data from the
monitor, then our config utility will not be able to identify the
monitor and write out the correct settings to the config file.

This appears to be what is happening here.  When DDC probing is not
available for any reason, the only way to configure the monitor
correctly, is to manually select it from the list of monitors supplied
in our MonitorsDb database.  If the monitor is not present in our
database, then it is an unknown monitor and will be given "failsafe"
settings, which will limit the resolutions and refresh rates similar
to Microsoft Windows safe mode.

If a monitor is unsupported, a customer, vendor, or partner can attach
the Microsoft Windows ".INF" file for the display to a bug report in
bugzilla, and we can add it and any other displays covered by the
same .INF file to a future update of the hwdata package.  Once the
update is released, the monitor should show up in the list of monitors
for manual selection.


>Of course changing these parameters manually is not the prefeered approach.  
>The OS needs the ablity to detect the attached monitor and set parameters 
>appropriately.

The OS does have that capability.  It is currently restricted to x86
architecture only, and it is done via VESA VBE, so it is limited to
what the video hardware's video bios provides.  There are other
factors that may limit or prevent DDC from working properly, such as
the aforementioned KVM switches, BIOS bugs, and even invalid or
incomplete DDC data coming from the monitor itself.

From the data you've provided above, it appears that your monitor
is not providing the horizontal and vertical sync frequencies to
the ddcprobe utility.  For testing purposes only, I would recommend
swapping the monitor with another monitor that is known to be
properly autodetected and configured on another system.  If the
other monitor works, that would be useful information to have.


Comment 12 Mike A. Harris 2005-07-16 09:20:49 EDT
Please review the previous comments and respond, so we can try to resolve
this issue soon.  It would be very helpful if you could indicate for each
monitor you've tried and had fail:

- Monitor brand and full model number
- The output of ddcprobe for each monitor tried (please try different
  brands/models if possible, and not just multiple of the same brand/model).
- The X server log for each monitor.

Also, please provide the Windows .INF file for each monitor that fails,
so that we can add support for it in a future release if it is not
already supported.

I've carbon copied Hui Yu at ATI, in case he has observed similar reports,
or has suggestions to add.

Thanks in advance for trying these suggestions.  Once we've gotten your
feedback, we will review the issue further and try to find a solution.
Comment 13 Mike A. Harris 2005-08-23 13:36:09 EDT
Changing status to NEEDINFO_REPORTER.  This issue is awaiting a response from
the original reporter, with the information that was previously requested.

Once that information is present in the bug report, we will proceed with our
investigation.

Thanks in advance.
Comment 14 Rod Macdonald 2005-08-23 14:13:41 EDT
This problem is now known to be related to specific ATI test cards that were 
used to test RN50 on Dell and Intel servers which did not have chip-down RN50 
solutions.  Early revisions of these cards (part number: A102-A51900-00, for 
internal use only) are known to have DDC problems.  This has been fixed in 
later revisions of the card. 

This bugzilla can be closed since it is not an OS issue.
Comment 15 Petros Koutoupis 2006-06-26 16:43:52 EDT
http://h18000.www1.hp.com/products/quickspecs/11847_div/11847_div.HTML

* The Management Processor Card provides basic graphic capabilities via
integrated Radeon 7000 2D graphics chip and 16 MB memory. VGA port is provided
on rear of the system. Supported resolutions and refresh rates include:

  	
OS     Minimum Resolution  Refresh Rate  Maximum Resolution  Refresh Rate
HP-UX     1024x768            75 Hz           1920x1200         75 Hz
Linux     1024x768            75 Hz           1920x1200         75 Hz
Windows    640x480            75 Hz           1600x1200         75 Hz
OpenVMS    640x480            60 Hz           1920x1200         75 Hz

Note You need to log in before you can comment on or make changes to this bug.