Bug 158208 - Filter creation doesn't occur when filters window is open
Filter creation doesn't occur when filters window is open
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-19 12:06 EDT by Jack Aboutboul
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 18:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 304816 None None None Never

  None (edit)
Description Jack Aboutboul 2005-05-19 12:06:13 EDT
Description of problem:
Creating a filter while the filter window is open will go through and complete
successfully, although the filter you are trying to will not ever be created. 

Version-Release number of selected component (if applicable):
2.0.4-4

How reproducible:
Always

Steps to Reproduce:
1. Open the filters window to view filters
2. Behind the open window try and create a filter
3. Filter dialog will close successfully
  
Actual results:
Filter dialog closes with no error yet no filter is created

Expected results:
Filter dialog should either close with an error or create the filter.

Additional info:
Comment 1 Dave Malcolm 2005-05-19 13:29:19 EDT
I just tried this in Evolution 2.2.2:
1: Open the filters window to view filters
2: Behind the open window try and create a filter (by right-clicking on an
email; Create Rule from Message->Filter on something... OK); filter does not
appear in the existing filter dialog.
3a: Press "Cancel" button in the filter dialog, reopen the filter dialog. 
Filter created in stage does appear in the new filter dialog
3b: Press "Ok" button in the filter dialog, reoper the filter dialog: filter
created in stage 2 does not appear.

So it looks like a the filter dialog really ought to update its state if you do
stage 2; arguably the filter dialog ought to be "instant apply" as well,
replacing the Cancel/OK buttons with a single "OK" button.

Please check upstream; if the bug is not already filed, please file one, and
link this bug to it.  Please CC me on the new or existing bug; thanks!

The upstream bug tracker is http://bugzilla.gnome.org

Note You need to log in before you can comment on or make changes to this bug.