Bug 158216 - Select All button for ID Combos
Select All button for ID Combos
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
rhn400
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ken Ganong
Vlady Zlatkin
:
Depends On:
Blocks: 151514
  Show dependency treegraph
 
Reported: 2005-05-19 13:22 EDT by Ken Ganong
Modified: 2007-04-18 13:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 16:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2005-05-19 13:22:35 EDT
In Java, the select all button doesn't work with id combos.  It either dies
because there is no id field in the dto or selects everything based on the id
field instead of the idCombo field.
Comment 1 Jesus M. Rodriguez 2005-06-10 14:36:11 EDT
Mass moving ON_DEV to ON_QA
Comment 2 Vlady Zlatkin 2005-06-27 20:56:25 EDT
where can this be seen and how can it be tested?
Comment 3 Ken Ganong 2005-06-28 09:51:53 EDT
Did this actually fail QA or is this a need info?

You can find this in the packages tab under system details.  I'm not sure if it
exists anywhere else, but it should work wherever it does (duh).  If you go to
/rhn/systems/details/packages/UpgradableList.do?sid=XXXX with a valid sid, you
should notice that the checkboxes have values like "500000839|700000657".  This
is an idCombo, composed of the Package Name Id piped together with the Package
EVR Id.

As you can imagine, IdCombos have to be treated a little differently for
selection which explains the existence of this bug as well as similar ones.

As for testing, press the select all button on these package pages and on any
other pages you find that have ID Combos.  Try pushing a new package which
applies to a system and hit the select all button again.
Comment 4 Vlady Zlatkin 2005-07-05 18:10:53 EDT
sdc:
PackageList.do
UpgradableList.do
InstallPackages.do
VerifyPackages.do

ssm:
verify.pxt
remove.pxt
upgrade.pxt
install_channel.pxt?cid=103


all look good

Note You need to log in before you can comment on or make changes to this bug.