This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 158292 - redhat-release is not upgraded through Satellite if /etc/issue is modified
redhat-release is not upgraded through Satellite if /etc/issue is modified
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-release (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Red Hat Satellite QA List
:
Depends On:
Blocks: 170852
  Show dependency treegraph
 
Reported: 2005-05-20 07:27 EDT by Wayne Pascoe
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: 3AS-13.7.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 13:17:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wayne Pascoe 2005-05-20 07:27:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050514 Fedora/1.0.4-0.fdr.1.2 Firefox/1.0.4

Description of problem:
When attempting to schedule redhat-release errata for update on a system with a modified /etc/issue (all of mine in other words), the update fails. The reason for the failure is that a config file has changed.

If /etc/issue is changed on a system to provide a company message, this package install fails. This can be circumvented by setting noReplaceConfig=0 in /etc/sysconfig/up2date. This is not an acceptable solution as it would expose real configuration files to risk.

Apparantly /etc/issue is seen as a configuration file, which seems unusual. This file does not affect the performance of the server or any application, nor do changes to this file affect operation of the server. This file is information only.

It is standard business practice to place a message to be displayed at login, often including legal disclaimer wording to authorise monitoring. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Schedule redhat-release update through satellite
2. Run rhn_check on server where update was scheduled for

  

Actual Results:  Install of package fails with message
Name                                    Version        Rel  Reason
-------------------------------------------------------------------------------
redhat-release                          3AS            13.5.1Config modified 

Expected Results:  Package should have installed, possibly backing /etc/issue up

Additional info:
Comment 1 Mihai Ibanescu 2005-05-20 08:52:35 EDT
Not really an up2date issue, reassigning to redhat-release.
Comment 2 Jason Smith 2005-05-31 17:03:53 EDT
I would like to add that while setting the noReplaceConfig to 0 does allow
up2date to install the new version without error, but it also replaces your
company banner with the default redhat one.  Actually it renames your modified
banner to /etc/issue.rpmsave before extracting the new redhat issue file.  This
must be because the issue file is defined like this in the spec file:

%config(noreplace) /ets/issue

This behavior needs to be changed to allow up2date to work in an environment
where company policy requires a customized login banner.

~Jason
Comment 7 Dennis Gregorovic 2006-05-01 13:17:17 EDT
I've confirmed that with the version of redhat-release included in RHEL 3 U7,
/etc/issue is now properly marked as %config(noreplace) and that up2date with a
modified /etc/issue results in package upgrade and the creation of /etc/issue.rpmnew

Note You need to log in before you can comment on or make changes to this bug.