Bug 158381 - module ipw2200 will not loaded
module ipw2200 will not loaded
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-21 06:23 EDT by Robert Maessen
Modified: 2015-01-04 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-10 17:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Maessen 2005-05-21 06:23:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
When booting the kernel and it comes to the part of networking it hangs a while and then showing "couldn,t open /dev/xxxxxx it is listen a lot of device numbers that it could not load, after that it goes to the swap space an boots on but whitout a network connection

Version-Release number of selected component (if applicable):
kernel 2.6.11-1.1323_FC4

How reproducible:
Always

Steps to Reproduce:
1.simply rebooting
2.even when loaded the module by hand it shows the same problem
3.
  

Actual Results:  same error

Expected Results:  the module should have loaded and networking should be possible

Additional info:

I always have a bit of a problem making that card working due to the Notebook, normal it solves itself by pressing the button for the wireless network during booting up, that also worked for all of the earlier versions of the kernel for fc4.
Comment 1 Dave Jones 2005-05-22 00:38:31 EDT
did you also update the firmware file ?
Comment 2 Robert Maessen 2005-05-22 04:49:25 EDT
Ipw2200-firmware-2.2.3 is the version that is used, I upgraded to version 2.3.6
the error isn't the same but I still can not bring it up.
It is trying to change the loopbak into eth1 in other words it does not see the
device correctly.
And all my normal tricks will not solve it.

(In reply to comment #1)
> did you also update the firmware file ?
> 

Comment 3 Bill Nottingham 2005-05-23 00:30:17 EDT
What's your ifcfg file look like? What messages do you get when loading the driver?
Comment 4 Robert Maessen 2005-05-23 04:20:45 EDT
My ifcfg-eth1 file looks like this:

IPV6INIT=no
ONBOOT=yes
USERCTL=no
TYPE=Wireless
DEVICE=eth1
HWADDR=00:00:00:00:00:00
BOOTPROTO=dhcp
DHCP_HOSTNAME=stripes
ESSID=3Com4linux
MODE=Managed
RATE='0 kb/s'
CHANNEL=1

Strangely enough I do not get any errors now when loading the module not with
modprobe and not with insmod.
But when I do a network restart or stop, start it starts again with interface
'devxxxxx' not found.
It still does not see the device.
I will update the machine on an other kernel now and see if it changes anything.
Comment 5 Bill Nottingham 2005-05-23 12:50:36 EDT
Do you have any ifcfg-devXXXX files, or 'alias devXXXX <something>' in
/etc/modprobe.conf?
Comment 6 Robert Maessen 2005-05-23 12:59:30 EDT
Out of my head it is something like 
alias eth1 ipw2200

I also updated the kernel to 2.6.11-1.1329_FC4
It also is impossible to bring that interface up in there (I couldn't do a
compleet update because of dependency problems with openoffice) and I didn't had
much time to doe so.
Comment 7 Robert Maessen 2005-05-25 08:04:20 EDT
Update:

Updated to kernel 2.6.11-1.1341_FC4
Same problem, I found something else now when shutting down I noticed a message;
ipw2200: radio frequeny kill switch is on, must be turned off.
Comment 8 Robert Maessen 2005-05-25 10:37:01 EDT
Update,
2.6.11-1.1353_FC4
The module is loaded but the device not found.
unloaded the module and started it with modprobe ipw2200 led=1
It knows that the divice is there the led changes when I press the button,
The rf_kill file shows 0
Still not able to find the device at boot up.
I,ve tried to change rf_kill to a different value but it changes back to 0 everytime
Comment 9 Robert Maessen 2005-05-25 10:54:08 EDT
During a rmmod ipw2200 after a reboot I got the following message from syslogd;
Disabling IRQ #10.

That was an error that I had before in the earlier kernels from FC3, I only
could solve that by building my own kernel.
It gave that error when initializing hardware during bootup
Comment 10 Robert Maessen 2005-05-25 11:29:34 EDT
Explain???
'cause I do not understand this..
I copied the hardware address from the device out of /etc/sysconfig/hwconf into
/etc/sysconfig/network-scripts/ifcfg-eth1 on its own it would come up everytime
with 00:00:00:00:00:00, also when I tried to get it's MAC address with
system-config-network.
After restarting the network it came up?? 
Comment 11 Robert Maessen 2005-05-25 11:56:52 EDT
After a reboot it came up without a problem, out of itself.
Mhhh, it looks like it can't determine its hardware address during the
iniatializing from the hardware although it's in its hwconf. 
Comment 12 Robert Maessen 2005-05-25 12:58:51 EDT
Due to the nature of this card (on - off button) shouldn't it be hotpluggable?
Comment 13 Bill Nottingham 2005-05-25 13:02:49 EDT
? It is hotpluggable; at least, I don't know of why it wouldn't be.
Comment 14 Robert Maessen 2005-05-25 13:06:49 EDT
That would be the first time that it would work then I never managed to bring
that device up when the system was running. 
Comment 15 Robert Maessen 2005-05-26 14:04:20 EDT
If somebody out there is trying to make my live difficult, you can tell him it's
working.....
Update kernel 2.6.11-1.1363_FC4,
dmesg:
ipw2200: detected Intel PRO/wireless
ipw2200: ipw-2.2-boot.fw load failed:Reason -2
ipw2200: Unable to load firmware: 0xFFFFFFFE
ipw2200: failed to register network device
ipw2200: probe for 0000:02:04 failed with error -5

After I unloaded the module and loading it again in the meantime holding the
button down it is present but I can not make a connection to the AP.
Comment 16 Robert Maessen 2005-05-26 14:20:22 EDT
During normal boot up I got the message ipw2200 device eth0 does not seems to be
present: delaying initializing.
When it is hotpluggable it should come up after pressing the button, right?
no newer version of ipw2200-firmware then I've got now...
Comment 17 Bill Nottingham 2005-05-26 16:20:15 EDT
ipw2200: ipw-2.2-boot.fw load failed:Reason -2

-2 means the file wasn't found. You need that version of the firmware for the
driver in 1363 (it was reverted because of various problems that were reported.)
Comment 18 Robert Maessen 2005-05-28 05:54:30 EDT
OK downgraded the firmware to 2.2-5 Still got an error it "sees" the device but
I can not bring it up.
modprobe ipw2200 led=1 doesn't work now, no way to find out how far it "sees"
the device. hardware address is back to 00:00:00:00:00:00 no hardware address in
hwconf anymore.
The messages in dmesg is still the same even after changing firmware version.
About that hotpluggable shouldn,t there be an entry in /etc/hotplug/pci for that
device then (maybe a stupid question I know)?
Comment 19 Robert Maessen 2005-05-28 07:02:45 EDT
mhhh, maybe time to start a new bug, but somehow I think that it is related to
this problem they both share IRQ 10, as I told before I always had a problem
with this card.
Also with the soundcard snd-intel8x0, to make that card work I have to unload
the module and load it again after that it works.
I've gone back to 1353, I understand what they are trying to do there, it also
looks like a better way to deal with it firmware 2.3-6, it nows the card is
there no matter if it is turned on or off, and yes I can turn it on and off when
the system is running, it even comes up.
What kind of problems did you had with it?
After changing that hardware address I didn't had any problems with it, the
network would not always come up after a reboot, after pressing the button and
activating the device in system-config-network it always came up.
A simple service network restart also works after pressing the button.

Now back to 2.2-5 firmware there is no way that I can bring it back up in 1363.
Comment 20 Robert Maessen 2005-06-01 14:25:43 EDT
Update,

Kernel 1366, no problem bringing the device up, it came up all by itself.
But does this mean that you stick with ipw2200 firmware 2.2 now?
Then it would help if you would give that firmware version by this release of FC4.
If tried to make it work with fimware 2.3 but that will not work at all.

Comment 21 Robert Maessen 2005-06-01 14:43:21 EDT
/etc/sysconfig/hwconf finds the mac address
Also probing it with system-config-network it finds the correct mac address, a
first in this firmware version.
Comment 22 Bill Nottingham 2005-06-01 14:46:29 EDT
The version in 1366 is 1.0.0, which uses version 2.2 of the firmware.

A later update *may* be version 1.0.4 of the driver, which will use version 2.3
of the firmware.

Closing, as it appears to work now.
Comment 23 Robert Maessen 2005-06-10 09:46:30 EDT
Confused now.

1381_FC5 but still rawhide release?
Well anyhow the module will not load 'cause there is no such device.
No message in dmesg about eth1 at all
Comment 24 Bill Nottingham 2005-06-10 12:59:19 EDT
* Thu Jun 09 2005 Dave Jones <davej@redhat.com>
- 2.6.12-rc6-git3
- Temporarily disable the ipw drivers until I sort them out.


The FC4 kernel does have them enabled.
Comment 25 Dave Jones 2005-06-10 17:42:05 EDT
This is fixed for FC4 release, and the FC5 (rawhide) kernel is intentionally
broken right now.
Comment 26 Robert Maessen 2005-06-10 17:47:58 EDT
OK Thanks,

I was just confused about it, I didn't know that your changing so fast to
another release, FC4 isn't released officiel yet.., although I could have know.

Note You need to log in before you can comment on or make changes to this bug.