Bug 158412 - 32bit Opteron using Segment Limits instead of NX
32bit Opteron using Segment Limits instead of NX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-05-21 23:29 EDT by Warren Togami
Modified: 2015-01-04 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-22 01:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2005-05-21 23:29:40 EDT
Description of problem:
FC4 32bit installed on a dual Opteron is using segment limits rather than NX.
dmesg says:
Using x86 segment limits to approximate NX protection

Remote KVM or ssh access is available upon request.  E-mail me your ssh pubkey.

Version-Release number of selected component (if applicable):
Comment 1 Warren Togami 2005-05-21 23:31:00 EDT
(And yes, "nx" is listed as a flag in /proc/cpuinfo.)
Comment 2 Dave Jones 2005-05-22 01:31:58 EDT
NX needs PAE, PAE isnt enabled in the UP 686 kernel.

Note You need to log in before you can comment on or make changes to this bug.