Bug 158492 - libgcj depends on openoffice???!!!
libgcj depends on openoffice???!!!
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-22 19:49 EDT by Jonathan S. Shapiro
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 00:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2005-05-22 19:49:35 EDT
Sorry if this is posted to wrong component -- cannot fund a libgcj component in
FC4test3.

The development/ tree is temporarily busted because somebody didn't push libjawt
into the tree. This led update of openoffice to fail, which prompted me to
update selectively.

Imagine my surprise to discover that libgcj depends on openoffice. This
definitely isn't right.

Imagine my further surprise to discover that there isn't any obvious bug
reporting component for libgcj!

The bad dependency exists in libgcj.i386-4.0.0-8.
Comment 1 Thomas Fitzsimmons 2005-05-26 00:03:52 EDT
$ rpm -q libgcj
libgcj-4.0.0-8

$ rpm -q --requires libgcj
/bin/sh  
/bin/sh  
/sbin/install-info  
/sbin/ldconfig  
config(libgcj) = 4.0.0-8
glib2 >= 2.4.0
gtk2 >= 2.4.0
ld-linux.so.2  
ld-linux.so.2(GLIBC_2.1)  
lib-gnu-java-awt-peer-gtk.so.6  
libXtst.so.6  
libart_lgpl >= 2.1.0
libart_lgpl_2.so.2  
libatk-1.0.so.0  
libc.so.6  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.2)  
libc.so.6(GLIBC_2.1.3)  
libc.so.6(GLIBC_2.2)  
libc.so.6(GLIBC_2.2.4)  
libc.so.6(GLIBC_2.3)  
libdl.so.2  
libdl.so.2(GLIBC_2.0)  
libdl.so.2(GLIBC_2.1)  
libgcc_s.so.1  
libgcc_s.so.1(GCC_3.0)  
libgcc_s.so.1(GCC_3.3)  
libgcc_s.so.1(GCC_3.3.1)  
libgcc_s.so.1(GLIBC_2.0)  
libgcj.so.6  
libgdk-x11-2.0.so.0  
libgdk_pixbuf-2.0.so.0  
libgij.so.6  
libglib-2.0.so.0  
libgmodule-2.0.so.0  
libgobject-2.0.so.0  
libgthread-2.0.so.0  
libgtk-x11-2.0.so.0  
libm.so.6  
libpango-1.0.so.0  
libpangox-1.0.so.0  
libpangoxft-1.0.so.0  
libpthread.so.0  
libpthread.so.0(GLIBC_2.0)  
libpthread.so.0(GLIBC_2.1)  
libpthread.so.0(GLIBC_2.2)  
libpthread.so.0(GLIBC_2.3.2)  
libz.so.1  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
zip >= 2.1

Anyway, all the libjawt confusion should be gone on Rawhide now.  Closing.

Note You need to log in before you can comment on or make changes to this bug.