Bug 158540 - gaim hangs in artsd
gaim hangs in artsd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libao (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-23 09:55 EDT by Dan Williams
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 09:09:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2005-05-23 09:55:18 EDT
At one point I ran 'kate', which fired up the KDE libs and services, including
artsd.  Now, gaim freezes when trying to connect, and the backtrace implicates
arts in some way.

Thread 1 (Thread -1208944960 (LWP 5132)):
#0  0x007887e2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0086730d in ___newselect_nocancel () from /lib/libc.so.6
#2  0x02bfd167 in Arts::StdIOManager::processOneEvent ()
   from /usr/lib/libmcop.so.1
#3  0x02bf0a8b in Arts::Dispatcher::connectUrl () from /usr/lib/libmcop.so.1
#4  0x02bf0cdd in Arts::Dispatcher::connectObjectRemote ()
   from /usr/lib/libmcop.so.1
#5  0x02e138d2 in Arts::SoundServer_base::_fromReference ()
   from /usr/lib/libsoundserver_idl.so.1
#6  0x02e13aa6 in Arts::SoundServer_base::_fromString ()
   from /usr/lib/libsoundserver_idl.so.1
#7  0x02d11c7c in arts_backend_init () from /usr/lib/libartscbackend.so.0
#8  0x00d182b3 in arts_init () from /usr/lib/libartsc.so.0
#9  0x004ff847 in ao_plugin_test () from /usr/lib/ao/plugins-2/libarts.so
#10 0x0072ccc2 in ao_default_driver_id () from /usr/lib/libao.so.2
#11 0x005d5fce in gaim_gtk_sound_get_ui_ops () from /usr/bin/gaim
#12 0x00560a16 in gaim_prefs_destroy () from /usr/bin/gaim
#13 0x005d59a2 in gaim_gtk_roomlist_init () from /usr/bin/gaim
#14 0x0056e512 in gaim_sound_play_file () from /usr/bin/gaim
#15 0x005d5e7d in gaim_gtk_roomlist_init () from /usr/bin/gaim
#16 0x0056e561 in gaim_sound_play_event () from /usr/bin/gaim
---Type <return> to continue, or q <return> to quit---
#17 0x005a1dc8 in gaim_gtk_conversations_get_win_ui_ops () from /usr/bin/gaim
#18 0x00550c28 in gaim_conv_im_write () from /usr/bin/gaim
#19 0x0056c0b3 in serv_got_im () from /usr/bin/gaim
#20 0x0077c409 in irc_msg_privmsg () from /usr/lib/gaim/libirc.so
#21 0x00777ba2 in irc_parse_msg () from /usr/lib/gaim/libirc.so
#22 0x007764bf in irc_chat_info_defaults () from /usr/lib/gaim/libirc.so
#23 0x005ac12a in gaim_gtkdialogs_remove_chat () from /usr/bin/gaim
#24 0x003d63ac in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#25 0x003b03ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0x003b33f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#27 0x003b36e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#28 0x00f8d1b5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x005dbebe in main () from /usr/bin/gaim

Why is it even talking to arts when I'm running GNOME?  Does it talk to arts
even if arts is fired up?  Killing artsd fixed the issue and allowed gaim to
proceed.
Comment 1 Luke Schierer 2005-05-23 18:06:04 EDT
this would be a bug in libao
Comment 2 Hans de Goede 2007-11-14 09:09:29 EST
Quick intro: I'm the new libao co-maintainer.

I cannot reproduce this with the latest liboa (0.8.8, will show in rawhide
soon), closing.

Note You need to log in before you can comment on or make changes to this bug.