Bug 158569 - Crash on Running iwconfig on ipw2100 driver
Crash on Running iwconfig on ipw2100 driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-23 13:22 EDT by Ryan Skadberg
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-13 08:52:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Skadberg 2005-05-23 13:22:29 EDT
With kernel-2.6.11-1.1340_FC4, got this crash when running the ifup script:

May 23 10:30:15 codewarrior kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000061
May 23 10:30:15 codewarrior kernel:  printing eip:
May 23 10:30:15 codewarrior kernel: f88ba2d4
May 23 10:30:15 codewarrior kernel: *pde = 00000000
May 23 10:30:15 codewarrior kernel: Oops: 0002 [#1]
May 23 10:30:15 codewarrior kernel: Modules linked in: radeon drm parport_pc lp
parport autofs4 sunrpc pcmcia video button battery ac md5 ipv6 yenta_socket
rsrc_nonstatic pcmcia_core uhci_hcd ehci_hcd snd_intel8x0m snd_intel8x0
snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore
snd_page_alloc ipw2100 ieee80211 ieee80211_crypt tg3 dm_snapshot dm_zero
dm_mirror ext3 jbd dm_mod
May 23 10:30:15 codewarrior kernel: CPU:    0
May 23 10:30:15 codewarrior kernel: EIP:    0060:[<f88ba2d4>]    Not tainted VLI
May 23 10:30:15 codewarrior kernel: EFLAGS: 00010046   (2.6.11-1.1340_FC4) 
May 23 10:30:15 codewarrior kernel: EIP is at
ieee80211_crypt_delayed_deinit+0x61/0x1e2 [ieee80211_crypt]
May 23 10:30:15 codewarrior kernel: eax: c1b33494   ebx: c1b33280   ecx:
00000061   edx: c1b33494
May 23 10:30:15 codewarrior kernel: esi: 00000202   edi: 00000000   ebp:
00000000   esp: f68c1e04
May 23 10:30:15 codewarrior kernel: ds: 007b   es: 007b   ss: 0068
May 23 10:30:15 codewarrior kernel: Process iwconfig (pid: 2700,
threadinfo=f68c1000 task=f5dd7550)
May 23 10:30:15 codewarrior kernel: Stack: 00000201 00000010 f5dd7550 f5dd7550
c03cea80 00000000 00000111 ffffffea 
May 23 10:30:15 codewarrior kernel:        c1b33280 c1b3349c f88ff857 c01f43cb
00000001 f68c1f54 c1b33280 c1b33000 
May 23 10:30:15 codewarrior kernel:        00000000 00000004 c1b3349c f68c1eb8
00001000 00000000 00000000 00000000 
May 23 10:30:15 codewarrior kernel: Call Trace:
May 23 10:30:15 codewarrior kernel:  [<f88ff857>]
ieee80211_wx_set_encode+0x2b6/0x4ee [ieee80211]
May 23 10:30:15 codewarrior kernel:  [<c01f43cb>] avc_has_perm_noaudit+0x26/0xd1
May 23 10:30:15 codewarrior kernel:  [<c0315e50>] wireless_process_ioctl+0x58d/0x6c3
May 23 10:30:15 codewarrior kernel:  [<f892899e>] ipw2100_wx_set_encode+0x0/0xb
[ipw2100]
May 23 10:30:15 codewarrior kernel:  [<c030b1d3>] dev_ioctl+0x242/0x28b
May 23 10:30:15 codewarrior kernel:  [<c02fed84>] sock_ioctl+0x0/0x244
May 23 10:30:15 codewarrior kernel:  [<c0193fd9>] do_ioctl+0x19/0x55
May 23 10:30:15 codewarrior kernel:  [<c0194107>] vfs_ioctl+0x50/0x1aa
May 23 10:30:15 codewarrior kernel:  [<c01942be>] sys_ioctl+0x5d/0x6b
May 23 10:30:15 codewarrior kernel:  [<c0103a51>] syscall_call+0x7/0xb
May 23 10:30:15 codewarrior kernel: Code: cc 01 00 00 01 00 00 00 c7 83 d8 01 00
00 d8 aa 8b f8 c7 83 dc 01 00 00 61 00 00 00 8d 93 14 02 00 00 8b 83 14 02 00 00
89 48 04 <89> 01 89 51 04 89 8b 14 02 00 00 8d 8b 30 02 00 00 8b 51 30 85
Comment 1 John W. Linville 2005-05-25 19:59:46 EDT
I think there may be a problem w/ the recent ipw2100 update to 1.1.0 in FC4.  
Please attempt to recreate this problem using the test kernels from here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please post your results.  Thanks! 
Comment 2 Ryan Skadberg 2005-05-25 20:45:37 EDT
The kernels from John worked much better.  The one minor thing is I got this
when installing:

WARNING:
/lib/modules/2.6.11-1.1355.2.2_FC4.jwltest.4/kernel/drivers/net/wireless/ipw2200/ipw2200.ko
needs unknown symbol ieee80211_freq_to_channel
WARNING:
/lib/modules/2.6.11-1.1355.2.2_FC4.jwltest.4/kernel/drivers/net/wireless/ipw2200/ipw2200.ko
needs unknown symbol ieee80211_get_geo
WARNING:
/lib/modules/2.6.11-1.1355.2.2_FC4.jwltest.4/kernel/drivers/net/wireless/ipw2200/ipw2200.ko
needs unknown symbol ieee80211_is_valid_channel


Doesn't affect me since I use ipw2100, but may cause issues for those using ipw2200.

Otherwise, been up and running for about 15 minutes without issue. (And before,
this crashed immediately)
Comment 3 John W. Linville 2005-05-26 09:44:51 EDT
Those ipw2200 warning are because I tinkered w/ the ieee80211 module w/o 
making the corresponding changes to the ipw2200 driver.  At least for ipw2100 
users, they can be ignored... :-) 
 
Someone else reported (in bug 158406) that the kernel-2.6.11-1.1363_FC4 kernel 
was working as well...would you mind giving that a try? 
Comment 4 Ryan Skadberg 2005-05-26 10:18:21 EDT
From the Changelog, it looks like 1363_FC4 reverted to the older IPW2100, is
this correct?
Comment 5 Dave Jones 2005-05-26 20:01:13 EDT
Correct. I'll do an update to the newer driver after the release, once its had
sufficient testing. Going to back to the last known good driver was the only way
we could freeze the kernel in time for FC4 release, and be sure that we werent
introducing further regressions.
Comment 6 John W. Linville 2005-05-27 12:47:59 EDT
Speaking of testing, I have test kernels based on 2.6.11-1.1363_FC4 w/ a 
different ipw2100 1.1.0 patch here:   
   
    http://people.redhat.com/linville/kernels/fc4/ 
 
Wanna give 'em a try?  Please post your results here...thanks! 
  
  
Comment 7 Ryan Skadberg 2005-06-23 21:22:25 EDT
Machine still crashes with latest rawhide kernels.  With
kernel-2.6.12-1.1395_FC5, I get this when NetworkManager starts:

Jun 23 18:44:46 codewarrior kernel: eth1: No xmit handler.
Jun 23 18:44:47 codewarrior kernel: divide error: 0000 [#1]
Jun 23 18:44:47 codewarrior kernel: Modules linked in: parport_pc lp parport
autofs4 sunrpc pcmcia video button battery ac md5 ipv6 yenta_socket rsrc_nonstatic
pcmcia_core uhci_hcd ehci_hcd snd_intel8x0m snd_intel8x0 snd_ac97_codec
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc ipw2100 ieee80211
ieee80211_crypt tg3 dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod
Jun 23 18:44:47 codewarrior kernel: CPU:    0
Jun 23 18:44:47 codewarrior kernel: EIP:    0060:[<f88ff0d6>]    Not tainted
VLIJun 23 18:44:47 codewarrior kernel: EFLAGS: 00010097   (2.6.12-1.1395_FC5)
Jun 23 18:44:47 codewarrior kernel: EIP is at ieee80211_wx_get_scan+0x736/0xbe6
[ieee80211]
Jun 23 18:44:47 codewarrior kernel: eax: ffff4f72   ebx: 0000b08e   ecx:
0000068a   edx: ffffffff
Jun 23 18:44:47 codewarrior kernel: esi: 00000036   edi: 00000000   ebp:
f5ef5ea6   esp: f5ef5da0
Jun 23 18:44:47 codewarrior kernel: ds: 007b   es: 007b   ss: 0068
Jun 23 18:44:47 codewarrior kernel: Process NetworkManager (pid: 2298,
threadinfo=f5ef5000 task=f5f90550)
Jun 23 18:44:47 codewarrior kernel: Stack: f5ef5ea3 00000029 f89000e5 0000000b
f89000e4 00000000 00000000 00000000
Jun 23 18:44:47 codewarrior kernel:        f6910007 f5ef5f54 c1a00280 c1a003cc
00000286 f6521000 5e8c0000 00000000
Jun 23 18:44:47 codewarrior kernel:        f652008f f652005d f6910000 00000000
00000000 00000000 00000000 00100000
Jun 23 18:44:47 codewarrior kernel: Call Trace:
Jun 23 18:44:47 codewarrior kernel:  [<c01f51db>]
avc_has_perm_noaudit+0x26/0xd1Jun 23 18:44:47 codewarrior kernel:  [<c01f52d4>]
avc_has_perm+0x4e/0x5a
Jun 23 18:44:47 codewarrior kernel:  [<c015ae3d>] check_poison_obj+0x24/0x17b
Jun 23 18:44:47 codewarrior kernel:  [<c015cd59>]
cache_alloc_debugcheck_after+0x31/0x11d
Jun 23 18:44:47 codewarrior kernel:  [<c0168886>] handle_mm_fault+0x240/0x31d
Jun 23 18:44:47 codewarrior kernel:  [<c015d300>] __kmalloc+0x7f/0xd0
Jun 23 18:44:47 codewarrior kernel:  [<c031b510>] wireless_process_ioctl+0x58d/0x6c3
Jun 23 18:44:47 codewarrior kernel:  [<f89289e3>] ipw2100_wx_get_scan+0x0/0xb
[ipw2100]
Jun 23 18:44:47 codewarrior kernel:  [<c030f973>] dev_ioctl+0x237/0x280
Jun 23 18:44:47 codewarrior kernel:  [<c0303364>] sock_ioctl+0x0/0x244
Jun 23 18:44:47 codewarrior kernel:  [<c0194ad9>] do_ioctl+0x19/0x55
Jun 23 18:44:47 codewarrior kernel:  [<c0194c07>] vfs_ioctl+0x50/0x1aa
Jun 23 18:44:47 codewarrior kernel:  [<c0194dbe>] sys_ioctl+0x5d/0x6b
Jun 23 18:44:47 codewarrior kernel:  [<c0103a51>] syscall_call+0x7/0xb
Jun 23 18:44:47 codewarrior kernel: Code: 0f be 41 5c 29 c3 8d 04 3f 01 f8 8d 04
c7 01 c0 01 c0 89 d1 c1 e1 04 29 d1 8d 34 1b 89 da c1 e2 06 29 f2 01 d1 0f af d9
29 d8 99 <f7> ff 89 c2 b8 64 00 00 00 80 fa 65 0f 42 c2 88 84 24 30 01 00

Works fine with kernel-2.6.11-1.1369_FC4
Comment 8 John W. Linville 2005-07-12 15:36:57 EDT
I think Dave may have corrected this w/ later kernels...is this still 
happening for you? 
Comment 9 Ryan Skadberg 2005-07-12 18:52:07 EDT
The "fix" in place is downgraded drivers.  Keep this open until we have a
working 1.1.0 or 1.1.1 (released today) in the kernel.
Comment 10 John W. Linville 2005-07-13 08:06:44 EDT
Sorry, that's not the way it works... :-)  
  
The version upgrade is a separate issue.  You can open a separate bugzilla for  
that if you like, although everyone is already aware of the need for the later  
version.  
Comment 11 John W. Linville 2005-07-13 08:09:58 EDT
BTW, I never got a report of testing the kernels from comment 6...it may be 
helpful to know if that version of the patch is working... 
Comment 12 Ryan Skadberg 2005-07-13 08:35:54 EDT
Wow, that's quite possibly the WORST piece of customer service I have EVER seen.

This bug was against a kernel with the ipw 1.1.0 drivers and until those drivers
with the kernel work, this should stay in place, it's ridiculous to close a bug
that is not resolved, it's just hidden at the moment by a downgrade.

This bug is in devel because the IPW2100 upgrade should be added there and
tested there.  This is an open issue at the moment and there should be an open
bug against them.
Comment 13 John W. Linville 2005-07-13 08:52:21 EDT
Then feel free to open a bugzilla that says "fedora needs ipw2100 version >=  
1.1.0"... 
  

Note You need to log in before you can comment on or make changes to this bug.