Bug 158582 - Absolute symlink on build in -devel interferes with --root installs
Absolute symlink on build in -devel interferes with --root installs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-23 15:24 EDT by Ignacio Vazquez-Abrams
Modified: 2015-01-04 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.11-1.1342
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-14 08:26:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to change build symlink to relative (550 bytes, patch)
2005-05-23 15:24 EDT, Ignacio Vazquez-Abrams
no flags Details | Diff

  None (edit)
Description Ignacio Vazquez-Abrams 2005-05-23 15:24:15 EDT
When building a module against a kernel where the -devel package is not
installed directly in / there is a problem due to the fact that that the build
symlink is absolute instead of relative. The attached patch corrects this.
Comment 1 Ignacio Vazquez-Abrams 2005-05-23 15:24:15 EDT
Created attachment 114733 [details]
Patch to change build symlink to relative
Comment 2 Dave Jones 2005-05-23 15:30:06 EDT
applied to CVS, will be in the next build.

Note You need to log in before you can comment on or make changes to this bug.