Bug 158586 - metakit puts architecture-specific files in /usr/lib on 64-bit arches
metakit puts architecture-specific files in /usr/lib on 64-bit arches
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metakit (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-23 15:43 EDT by Bill Nottingham
Modified: 2014-03-16 22:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 11:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-05-23 15:43:56 EDT
Description of problem:

/usr/lib/libmk4.so
/usr/lib/tcl8.4/Mk4tcl
/usr/lib/tcl8.4/Mk4tcl/Mk4tcl.so
/usr/lib/tcl8.4/Mk4tcl/pkgIndex.tcl
/usr/lib/libmk4.a

Should be /usr/lib64.

Appears to be built against the wrong version of python too.

Version-Release number of selected component (if applicable):

2.4.9.3-4
Comment 1 Matthias Saou 2005-05-26 08:51:17 EDT
The wrong version of python is because this package was still the one copied
over from FC3, since it failed the mass rebuilds with gcc4.

A patch was included in bug #158460 to fix the rebuild problem, and I've now
made further changes :
- Moved the python module to site-packages
- Moved the main libmk4.so to _libdir
- Kept the tcl stuff in _prefix/lib (as that's where tcl is, apparently)
- Disabled the explicit stripping of the lib and python lib
Comment 2 Matthias Saou 2005-05-26 11:29:14 EDT
The rebuild went fine, expect the fixed packages to appear in development any
time now.

Note You need to log in before you can comment on or make changes to this bug.