Bug 1585999 - Content -> RH Subscriptions => Deface warnings + RoutingError
Summary: Content -> RH Subscriptions => Deface warnings + RoutingError
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: sat6-team-ux
QA Contact: Lukáš Hellebrandt
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1609324 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-05 09:19 UTC by Lukáš Hellebrandt
Modified: 2019-08-01 18:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-01 18:35:13 UTC


Attachments (Terms of Use)
foreman-tail.log (17.05 KB, text/plain)
2018-06-05 11:50 UTC, Lukáš Hellebrandt
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 23990 None None None 2018-06-18 23:01:53 UTC

Description Lukáš Hellebrandt 2018-06-05 09:19:25 UTC
Description of problem:
When going to Content -> Red Hat Subscriptions in the WebUI, I get some Deface warnings, e.g.

"""
No :original defined for 'theme_resources', you should change its definition to include:
 :original => '832bbb11950755069021b93378fd070290792022'
"""

, and a RoutingError

"""
ActionController::RoutingError (No route matches [GET] "/javascripts/bastion/angular-i18n/angular-locale_en.js"):
2018-06-05T05:10:53 [F|app|]
2018-06-05T05:10:53 [F|app|] katello (3.7.0.0.5) lib/katello/prevent_json_parsing.rb:12:in `call'
"""

, foreman-tail log attached.

Version-Release number of selected component (if applicable):
Sat 6.4 snap 6

How reproducible:
Deterministic

Steps to Reproduce:
In WebUI, go to Content -> Red Hat Subscriptions while tailing the logs

Actual results:
Warnings, error, but the page loads

Expected results:
The page laods without warnings and errors

Additional info:
Reporting as WebUI problem because this happens in english version, feel free to switch this to Localization and Internatiolization issue if more appropriate

Comment 1 Lukáš Hellebrandt 2018-06-05 11:50:26 UTC
Created attachment 1447843 [details]
foreman-tail.log

Comment 3 Walden Raines 2018-06-18 22:55:28 UTC
Created redmine issue http://projects.theforeman.org/issues/23990 from this bug

Comment 4 Walden Raines 2018-06-18 22:56:12 UTC
This may not apply anymore with the new RH subscriptions page.  Will investigate.

Comment 5 Brad Buckingham 2018-07-27 20:56:10 UTC
*** Bug 1609324 has been marked as a duplicate of this bug. ***

Comment 6 Brad Buckingham 2018-07-27 21:08:03 UTC
I have marked bug 1609324 as a duplicate of this one.

When resolving this bug, please be aware that the error below is being generated in multiple scenarios; therefore, the solution should address those as well.

Comment 8 Bryan Kearney 2019-07-02 18:01:56 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 9 Bryan Kearney 2019-08-01 18:35:13 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.