This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 158695 - partprobe using deprecated SCSI ioctl
partprobe using deprecated SCSI ioctl
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-24 17:52 EDT by Eric Bursley
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 11:16:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Bursley 2005-05-24 17:52:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
After creating new partitions, I ran parted to have the kernel rescan the partitions so that I could create PV and import them into a Volume Group.  I received the following errors:
program partprobe is using a deprecated SCSI ioctl, please convert it to SG_IO
program partprobe is using a deprecated SCSI ioctl, please convert it to SG_IO

In addition, I am not able to execute any commands after that.  I receive the following errors:
[root@ref2850 ~]# which parted
-bash: /usr/bin/which: cannot execute binary file
[root@ref2850 ~]# reboot
-bash: /sbin/reboot: cannot execute binary file
[root@ref2850 ~]# sysreport
-bash: /usr/sbin/sysreport: cannot execute binary file

I have to hard reboot the server.


Version-Release number of selected component (if applicable):
parted-1.6.19-1.EL

How reproducible:
Always

Steps to Reproduce:
1. Partition new lun on server
2. run partprobe to rescan new partitions
3.
  

Actual Results:  system was very flakey, and needed a hard reboot to resolve problems

Expected Results:  new partitions became available for use.  System stability is normal

Additional info:

I can submit a sysreport when this bug is assigned
Comment 1 Chris Lumens 2005-05-25 11:28:56 EDT
Where are you getting partprobe from?  I don't see it anywhere on the system
until after the parted package has been installed.
Comment 2 Eric Bursley 2005-05-25 11:45:14 EDT
Partprobe is a componet of the parted package.  
[eric@B8ZHF01 ~]$ rpm -qi parted
Name        : parted                       Relocations: (not relocatable)
Version     : 1.6.19                            Vendor: Red Hat, Inc.
Release     : 1.EL                          Build Date: Tue 30 Nov 2004 04:55:05
PM CST
Install Date: Mon 14 Mar 2005 10:50:15 AM CST      Build Host:
tweety.build.redhat.com
Group       : Applications/System           Source RPM: parted-1.6.19-1.EL.src.rpm
Size        : 1238283                          License: GPL
Signature   : DSA/SHA1, Wed 05 Jan 2005 04:52:16 PM CST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The GNU disk partition manipulation program.
Description :
The GNU Parted program allows you to create, destroy, resize, move,
and copy hard disk partitions. Parted can be used for creating space
for new operating systems, reorganizing disk usage, and copying data


[eric@B8ZHF01 ~]$ rpm -ql parted
/sbin/parted
/sbin/partprobe
/usr/lib/libparted-1.6.so.12
/usr/lib/libparted-1.6.so.12.0.7
/usr/lib/libparted.so
/usr/share/doc/parted-1.6.19
/usr/share/doc/parted-1.6.19/API
/usr/share/doc/parted-1.6.19/AUTHORS
/usr/share/doc/parted-1.6.19/BUGS
/usr/share/doc/parted-1.6.19/COPYING
/usr/share/doc/parted-1.6.19/ChangeLog
/usr/share/doc/parted-1.6.19/FAT
/usr/share/doc/parted-1.6.19/NEWS
/usr/share/doc/parted-1.6.19/README
/usr/share/doc/parted-1.6.19/THANKS
/usr/share/doc/parted-1.6.19/TODO
/usr/share/info/parted.info.gz
/usr/share/locale/ca/LC_MESSAGES/parted.mo
/usr/share/locale/cs/LC_MESSAGES/parted.mo
/usr/share/locale/da/LC_MESSAGES/parted.mo
/usr/share/locale/de/LC_MESSAGES/parted.mo
/usr/share/locale/es/LC_MESSAGES/parted.mo
/usr/share/locale/fr/LC_MESSAGES/parted.mo
/usr/share/locale/gl/LC_MESSAGES/parted.mo
/usr/share/locale/it/LC_MESSAGES/parted.mo
/usr/share/locale/ja/LC_MESSAGES/parted.mo
/usr/share/locale/nl/LC_MESSAGES/parted.mo
/usr/share/locale/nn/LC_MESSAGES/parted.mo
/usr/share/locale/pl/LC_MESSAGES/parted.mo
/usr/share/locale/pt/LC_MESSAGES/parted.mo
/usr/share/locale/pt_BR/LC_MESSAGES/parted.mo
/usr/share/locale/ru/LC_MESSAGES/parted.mo
/usr/share/locale/sv/LC_MESSAGES/parted.mo
/usr/share/locale/tr/LC_MESSAGES/parted.mo
/usr/share/locale/uk/LC_MESSAGES/parted.mo
/usr/share/locale/zh_CN/LC_MESSAGES/parted.mo
/usr/share/man/man8/parted.8.gz
/usr/share/man/man8/partprobe.8.gz
/usr/share/man/pt_BR/man8
/usr/share/man/pt_BR/man8/parted.8.gz
Comment 3 Chris Lumens 2005-05-26 11:54:26 EDT
Oh yes, I thought you were originally saying you were using partprobe from
within the installation system, hence my question.  I don't believe the
deprecated ioctl message could be causing the other problems you're
experiencing.  What are the exact steps you're taking that are leading up to the
problem?
Comment 4 Eric Bursley 2005-05-26 15:36:18 EDT
Here are the steps I used:
Installed RHEL 4 x86 on a PE 2850 server.  SELinux is disabled.
Update all packages to latest versions using RHN Satellite server.
Boot to new kernel 2.6.9-5.0.5.ELsmp
Install qla2xxx-V8.0.0.03-1dkms rpm for support of Qlogic 2360 HBAs
Install Powerpath 4.4.0-332
Present 2 Luns from CX700 Dell EMC array.
Reboot
use fdisk to partition new luns.
Partitions do not appear in /dev, and I can not use mke2fs -j to put down file
system because device is not present.
run partprobe.  Partitions are detected, and I can use mke2fs -j to put down a
file system.  However I receive error messages from many other commands, as I
previously listed, and the system is now unstable, and needs to be hard booted.
This system is a test system, so I can pretty much do what ever is needed.
Comment 5 Karel Zak 2005-06-08 18:47:59 EDT
BTW, the util partprobe uses libparted where is almost all code of the parted.
Comment 6 Chris Lumens 2005-06-09 14:30:22 EDT
The deprecated ioctl warning is now taken care of in upstream CVS and can be
backported to a RHEL4 update if required.

I still don't think this is the real problem, however.  From your steps above,
my only question would be if there's a reason you are using fdisk to make the
new partitions instead of using parted itself.  Is there a difference if you use
parted?
Comment 7 Chris Lumens 2005-06-09 14:49:02 EDT
Additional thoughts - do the parted, sysreport, and reboot commands work before
you run fdisk or partprobe?  Can you run "file" on any of those commands and
report back what it says?  Which kernel are you booting?  Did you do an x86 or
x86_64 installation?  Do you somehow have binaries from both installed?  Can you
run the machine for a while before doing anything without it having problems, or
do they only start once you use partprobe?
Comment 8 Eric Bursley 2005-06-09 14:50:17 EDT
This problem was corrected with a newer version of Powerpath 4.4 beta, and
shouldn't be a problem once Powerpath 4.4 becomes gold.
Comment 9 Chris Lumens 2005-09-23 11:16:40 EDT
Closing due to information in comment #8.  Please reopen if you continue to see
this problem.

Note You need to log in before you can comment on or make changes to this bug.