Bug 158709 - cpan2rpm fails if source tar doesn't have slashes after directory names
cpan2rpm fails if source tar doesn't have slashes after directory names
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cpan2rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-24 22:07 EDT by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.028-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 09:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the bug (743 bytes, patch)
2005-05-24 22:07 EDT, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2005-05-24 22:07:57 EDT
I found a source tar in CPAN (Char-2.3.tar.gz) which doesn't have slashes at 
the end of directory names when you do "tar tzf" on it.  This causes cpan2rpm 
to fail because it expects the slash.  The attached patch fixes this.
Comment 1 Jonathan Kamens 2005-05-24 22:07:58 EDT
Created attachment 114809 [details]
patch to fix the bug
Comment 2 Gavin Henry 2005-05-25 03:31:15 EDT
Thanks for this.

I'll check out your patch later this week.

That's the best I can do at the moment ;-)

Thanks,

Gavin.
Comment 3 Christian Iseli 2007-01-19 02:22:21 EST
This bug hasn't been updated in a long time and targets FE devel.
Could you please check that it still occurs with current FE devel and update
accordingly ?

Thanks.

Note You need to log in before you can comment on or make changes to this bug.