Bug 158793 - usb mass storage error message
usb mass storage error message
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-25 15:53 EDT by fedrick
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 14:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fedrick 2005-05-25 15:53:11 EDT
Description of problem: After attaching a USB mass storage device to machine I 
see the error:
 
WARNING: USB Mass Storage data integrity not assured

Here are the entire contents of dmesg:


Linux version 2.4.21-27.0.2.EL (bhcompile@tweety.build.redhat.com) (gcc 
version 3.2.3 20030502 (Red Hat Linux 3.2.3-47)) #1 Wed Jan 12 23:46:37 EST 
2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001ff74000 (usable)
 BIOS-e820: 000000001ff74000 - 000000001ff76000 (ACPI NVS)
 BIOS-e820: 000000001ff76000 - 000000001ff97000 (ACPI data)
 BIOS-e820: 000000001ff97000 - 0000000020000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fecf0000 - 00000000fecf1000 (reserved)
 BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
 BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
511MB LOWMEM available.
NX protection not present; using segment protection
On node 0 totalpages: 130932
zone(0): 4096 pages.
zone(1): 126836 pages.
zone(2): 0 pages.
Kernel command line: ro root=LABEL=/
Initializing CPU#0
Detected 2793.076 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 5570.56 BogoMIPS
Page-cache hash table entries: 131072 (order: 7, 512 KB)
Page-pin hash table entries: 32768 (order: 5, 128 KB)
Dentry cache hash table entries: 65536 (order: 7, 512 KB)
Inode cache hash table entries: 32768 (order: 6, 256 KB)
Buffer cache hash table entries: 32768 (order: 5, 128 KB)
Memory: 508852k/523728k available (1539k kernel code, 12316k reserved, 1071k 
data, 164k init, 0k highmem)
zapping low mappings.
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: bfebfbff 00000000 00000000 00000000
CPU:             Common caps: bfebfbff 00000000 00000000 00000000
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 09
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
Process timing init...done.
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfba61, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
Transparent bridge - Intel Corp. 82801BA/CA/DB/EB PCI Bridge
PCI: Using IRQ router PIIX [8086/24d0] at 00:1f.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
Total HugeTLB memory allocated, 0
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
aio_setup: num_physpages = 32733
aio_setup: sizeof(struct page) = 56
Hugetlbfs mounted.
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ 
SERIAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS1 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 256 RAM disks of 8192K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH5: IDE controller at PCI slot 00:1f.1
PCI: Found IRQ 9 for device 00:1f.1
PCI: Sharing IRQ 9 with 00:1d.2
PCI: Sharing IRQ 9 with 00:1f.2
PCI: Sharing IRQ 9 with 02:0c.0
ICH5: chipset revision 2
ICH5: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
hda: ST340014A, ATA DISK drive
blk: queue c041a500, I/O limit 4095Mb (mask 0xffffffff)
hdc: GCR-8483B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 78125000 sectors (40000 MB) w/2048KiB Cache, CHS=4863/255/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 hda3
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing IPsec netlink socket
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 247k freed
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
libata version 1.02 loaded.
ata_piix version 1.02
PCI: Found IRQ 9 for device 00:1f.2
PCI: Sharing IRQ 9 with 00:1d.2
PCI: Sharing IRQ 9 with 00:1f.1
PCI: Sharing IRQ 9 with 02:0c.0
PCI: Setting latency timer of device 00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0xFE00 ctl 0xFE12 bmdma 0xFEA0 irq 9
ata2: SATA max UDMA/133 cmd 0xFE20 ctl 0xFE32 bmdma 0xFEA8 irq 9
ata1: SATA port has no device.
ata2: SATA port has no device.
scsi0 : ata_piix
scsi1 : ata_piix
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 164k freed
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 23:53:58 Jan 12 2005
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 11 for device 00:1d.0
PCI: Sharing IRQ 11 with 00:1d.3
PCI: Setting latency timer of device 00:1d.0 to 64
usb-uhci.c: USB UHCI at I/O 0xff80, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 10 for device 00:1d.1
PCI: Setting latency timer of device 00:1d.1 to 64
usb-uhci.c: USB UHCI at I/O 0xff60, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 9 for device 00:1d.2
PCI: Sharing IRQ 9 with 00:1f.1
PCI: Sharing IRQ 9 with 00:1f.2
PCI: Sharing IRQ 9 with 02:0c.0
PCI: Setting latency timer of device 00:1d.2 to 64
usb-uhci.c: USB UHCI at I/O 0xff40, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 11 for device 00:1d.3
PCI: Sharing IRQ 11 with 00:1d.0
PCI: Setting latency timer of device 00:1d.3 to 64
usb-uhci.c: USB UHCI at I/O 0xff20, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 4
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
PCI: Found IRQ 5 for device 00:1d.7
PCI: Setting latency timer of device 00:1d.7 to 64
ehci-hcd 00:1d.7: Intel Corp. 82801EB USB2
ehci-hcd 00:1d.7: irq 5, pci mem e0893800
usb.c: new USB bus registered, assigned bus number 5
ehci-hcd 00:1d.7: enabled 64bit PCI DMA
PCI: 00:1d.7 PCI cache line size set incorrectly (0 bytes) by BIOS/FW.
PCI: 00:1d.7 PCI cache line size corrected to 128.
ehci-hcd 00:1d.7: USB 2.0 enabled, EHCI 1.00, driver 2003-Jan-22
hub.c: USB hub found
hub.c: 8 ports detected
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), internal journal
Adding Swap: 2040244k swap-space (priority -1)
hub.c: connect-debounce failed, port 1 disabled
hub.c: new USB device 00:1d.7-3, assigned address 2
usb.c: USB device 2 (vend/prod 0x59f/0x421) is not claimed by any active 
driver.
hub.c: new USB device 00:1d.7-4, assigned address 3
usb.c: USB device 3 (vend/prod 0x59f/0x421) is not claimed by any active 
driver.
hub.c: new USB device 00:1d.7-5, assigned address 4
usb.c: USB device 4 (vend/prod 0x59f/0x421) is not claimed by any active 
driver.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
hub.c: new USB device 00:1d.7-6, assigned address 5
usb.c: USB device 5 (vend/prod 0x59f/0x421) is not claimed by any active 
driver.
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi2 : SCSI emulation for USB Mass Storage devices
  Vendor: LaCie     Model: BiggerDisk G931   Rev: 922 
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sda at scsi2, channel 0, id 0, lun 0
SCSI device sda: 1953588673 512-byte hdwr sectors (1000237 MB)
 sda: sda1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
scsi3 : SCSI emulation for USB Mass Storage devices
  Vendor: LaCie     Model: BiggerDisk G931   Rev: 922 
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sdb at scsi3, channel 0, id 0, lun 0
SCSI device sdb: 1953588673 512-byte hdwr sectors (1000237 MB)
 sdb: sdb1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
scsi4 : SCSI emulation for USB Mass Storage devices
  Vendor: LaCie     Model: BiggerDisk G931   Rev: 922 
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sdc at scsi4, channel 0, id 0, lun 0
SCSI device sdc: 1953588673 512-byte hdwr sectors (1000237 MB)
 sdc: sdc1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 4
scsi5 : SCSI emulation for USB Mass Storage devices
  Vendor: LaCie     Model: BiggerDisk G931   Rev: 922 
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sdd at scsi5, channel 0, id 0, lun 0
SCSI device sdd: 1953588673 512-byte hdwr sectors (1000237 MB)
 sdd: sdd1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 5
USB Mass Storage support registered.
inserting floppy driver for 2.4.21-27.0.2.EL
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077


Version-Release number of selected component (if applicable):

Linux biad253.v3.uthscsa.edu 2.4.21-27.0.2.EL #1 Wed Jan 12 23:46:37 EST 2005 
i686 i686 i386 GNU/Linux

How reproducible:

every reboot


Steps to Reproduce:
1.attach usb mass storage
2.boot
3.
  
Actual results:

error message


Expected results:

no error message


Additional info:

I contacted RedHat and they suggested I submit this bug report.
Comment 1 Pete Zaitcev 2005-05-25 22:47:22 EDT
Kernel 2.4 always had this message (I do not remember about 2.2).
We shipped this code since RHL 7.1. Why is this an issue now?
Comment 2 fedrick 2005-05-26 10:04:43 EDT
(In reply to comment #1)
> Kernel 2.4 always had this message (I do not remember about 2.2).
> We shipped this code since RHL 7.1. Why is this an issue now?

We just recently started using USB mass storage.  I was just wondering if we 
should use external USB hard drives to store important data.
Comment 3 Pete Zaitcev 2005-05-26 14:38:34 EDT
The issue, as it is understood now, is not the risk of data corruption
as such, but a risk of silent data corruption, in particular on write.
None of USB storage protocols was designed with robust error detection.
The risk varies greatly with cabling, USB-2-IDE adapter firmware and so on,
from insignificant to severe.

The message was not specific enough for action by the end user, and so it
was removed in 2.6 (as we ship with RHEL 4). However, I do not think
it is warranted to remove it in RHEL 3. Every patch is a maintenance burden.

If the data is sufficiently important, a top level checksumming and
scrubbing has to be implemented in the application software.
Otherwise, just hit the configuration well in testing, then
make it physically secure (do not allow extra devices on USB bus
after deployment).

Note You need to log in before you can comment on or make changes to this bug.