Bug 158820 - Updated vte may mangle xterminal prompt with some PS1 settings
Summary: Updated vte may mangle xterminal prompt with some PS1 settings
Status: CLOSED DUPLICATE of bug 158716
Alias: None
Product: Fedora
Classification: Fedora
Component: vte   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-26 02:17 UTC by Barry Wright
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 02:29:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Barry Wright 2005-05-26 02:17:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414

Description of problem:
Updated from vte-0.11.11-6 to vte-0.11.13-1.fc3. Users reported gnome-terminal (gnome-terminal-2.7.3-1) prompt was displaying additional characters that originate from the promt environment variable value.                                                                                  

Version-Release number of selected component (if applicable):
vte-0.11.13-1.fc3

How reproducible:
Always

Steps to Reproduce:
1.Update to vte-0.11.13-1.fc3
2.Set prompt var to PS1='\[\033[0;1m\][${PWD}]\[\033[0;m\]$ '
3.Start a gnome-terminal
  

Actual Results:  Prompt displayed as
[/home/username]^[[0;m$

Expected Results:  Prompt displayed as
[/home/username]$

Additional info:

Reverted to vte-0.11.11-6, closed all open gnome-terminals, opened a new terminal and the prompt was displayed correctly without the additional characters.There have not been any reports of the additional characters causing problems in other applications.

The same additional characters appears with the kde terminal as well.

Comment 1 Barry Wright 2005-05-26 02:29:50 UTC

*** This bug has been marked as a duplicate of 158716 ***


Note You need to log in before you can comment on or make changes to this bug.