This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 158863 - Line removing -fno-rtti and -fno-exceptions in gcc4.spec has no effect
Line removing -fno-rtti and -fno-exceptions in gcc4.spec has no effect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-26 08:24 EDT by Robin Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 08:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-05-26 08:24:17 EDT
Description of problem:
The following line in gcc4.spec has no effect:

OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g'`

because it is immediately followed by this line:

OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/\(-Wp,\)\?-D_FORTIFY_SOURCE=[12]//g'`

which throws away the old value of $OPT_FLAGS. The line should be removed (if
unneeded) or corrected (if needed).

Version-Release number of selected component (if applicable):
gcc-4.0.0-8
Comment 1 Jakub Jelinek 2005-05-26 08:52:19 EDT
The first line is not needed, I have removed it from CVS so that it doesn't
confuse.  Will show up in the next build, but as it is actually not any bug,
might not make into FC4 release.

Note You need to log in before you can comment on or make changes to this bug.