Bug 158869 - I get "/var/tmp/rpm-tmp.21876: line 2: gdk-pixbuf-query-loaders: command not found" when installing librsvg2-2.2.3-6.i386.rpm.
Summary: I get "/var/tmp/rpm-tmp.21876: line 2: gdk-pixbuf-query-loaders: command not ...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: librsvg2 (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-26 14:04 UTC by Thomas Cameron
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:01:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Cameron 2005-05-26 14:04:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
Installed RHEL 3 ES orignal release (i.e. not update X) from CDs.  Ran up2date -u.  Twice it timed out saying "too many open files /var/log/up2date," but I was able to restart it fine.  When up2date -u completed, I saw the error message

/var/tmp/rpm-tmp.21876: line 2: gdk-pixbuf-query-loaders: command not found

I figured out that the error was coming from librsvg2-2.2.3-6.i386.rpm.  I found that there was a command in /usr/bin called gdk-pixbuf-query-loaders-32, but nothing called gdk-pixbuf-query-loaders.

I uninstalled librsvg2 and it dependencies (eog nautilus gdm eel2 librsvg2-devel gdm nautilus-media gedit eel2-devel), then re-installed all of them using the command "up2date librsvg2 eog nautilus gdm eel2 librsvg2-devel gdm nautilus-media gedit eel2-devel" and the installation did not throw any error messages.  I guess it is fixed.

Version-Release number of selected component (if applicable):
librsvg2-2.2.3-6

How reproducible:
Didn't try

Steps to Reproduce:
1. Install RHEL 3 ES from original CDs
2. Run up2date -u

Actual Results:  Got the error "/var/tmp/rpm-tmp.21876: line 2: gdk-pixbuf-query-loaders: command not found"

Expected Results:  No error

Additional info:

[root@nobelium up2date]# rpm -e librsvg2 eog nautilus gdm eel2 librsvg2-devel gdm nautilus-media gedit eel2-devel
[root@nobelium up2date]# up2date librsvg2 eog nautilus gdm eel2 librsvg2-devel gdm nautilus-media gedit eel2-devel
Invalid metapkg id emacs-nox

Fetching Obsoletes list for channel: rhel-i386-es-3...

Fetching Obsoletes list for channel: rhel-i386-es-3-extras...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
eel2                                    2.2.4          3.E               i386
eel2-devel                              2.2.4          3.E               i386
eog                                     2.2.2          1                 i386
gdm                                     2.4.1.6        10                i386
gedit                                   2.2.2          4                 i386
librsvg2                                2.2.3          6                 i386
librsvg2-devel                          2.2.3          6                 i386
nautilus                                2.2.4          6.E               i386
nautilus-media                          0.2.1          5.1E              i386


Testing package set / solving RPM inter-dependencies...
########################################
eel2-2.2.4-3.E.i386.rpm:    ########################## Done.
eel2-devel-2.2.4-3.E.i386.r ########################## Done.
eog-2.2.2-1.i386.rpm:       ########################## Done.
gdm-2.4.1.6-10.i386.rpm:    ########################## Done.
gedit-2.2.2-4.i386.rpm:     ########################## Done.
librsvg2-2.2.3-6.i386.rpm:  ########################## Done.
librsvg2-devel-2.2.3-6.i386 ########################## Done.
nautilus-2.2.4-6.E.i386.rpm ########################## Done.
nautilus-media-0.2.1-5.1E.i ########################## Done.
Preparing              ########################################### [100%]

Installing...
   1:librsvg2               ########################################### [100%]
   2:eel2                   ########################################### [100%]
   3:eog                    ########################################### [100%]
   4:nautilus               ########################################### [100%]
   5:librsvg2-devel         ########################################### [100%]
   6:eel2-devel             ########################################### [100%]
   7:gdm                    ########################################### [100%]
   8:gedit                  ########################################### [100%]
   9:nautilus-media         ########################################### [100%]
[root@nobelium up2date]# which gdk-pixbuf-query-loaders
/usr/bin/which: no gdk-pixbuf-query-loaders in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)
[root@nobelium up2date]# which gdk-pixbuf-query-loaders-32
/usr/bin/gdk-pixbuf-query-loaders-32

Comment 1 David Juran 2005-05-27 14:20:54 UTC
Duplicate of bug 143547 ?

Comment 2 Thomas Cameron 2006-03-19 05:21:16 UTC
this is old and long since fixed.  please close it?

Comment 3 RHEL Product and Program Management 2007-10-19 19:01:33 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.