Bug 158874 - support for wpa setup in wireless dialog
support for wpa setup in wireless dialog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-26 10:15 EDT by Rudolf Kastl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 11:57:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2005-05-26 10:15:55 EDT
Description of problem:
Its not possible to setup wpa support with system-config-network yet. this is
untrivial for an end user. wep support is pretty insufficient protection.

Version-Release number of selected component (if applicable):
any future releases

How to solve?
Maybe add some wpa setup functionality to the wireless wizard.
Comment 1 Harald Hoyer 2005-09-14 08:57:46 EDT
with which tool do you enable wpa?
Comment 2 Rudolf Kastl 2005-09-14 10:21:02 EDT
wpa_supplicant is the tool i personally use to enable wpa with my centrino 
thinpad r51. 
to make it work with that laptop i had to build the latest unstable version of 
the ipw2200 driver and also build latest ieee modules.

xsupplicant exists too but as far as i know it doesent have built in encryption 
support.

regards,
Rudolf Kastl
Comment 3 Rudolf Kastl 2005-09-14 10:22:58 EDT
additionally it could also be made possible to use wpa2. would be a "nice to 
have" and it would move wireless support definitely up to par with other 
commercial operating systems.

regards,
Rudolf Kastl
Comment 5 Harald Hoyer 2005-09-15 03:48:23 EDT
well, as long as there is nothing in Core or Extras, I will not add s.th.
you may provide patches to s-c-network :)
Comment 6 Rudolf Kastl 2005-09-19 06:17:27 EDT
xsupplicant is part of fedora extras
Comment 7 Rudolf Kastl 2006-02-15 11:57:57 EST
wpa supplicant is there now (in rawhide) but NetworkManager does the job like a
charm.

since i initially made the request i am going to close it aswell. NetworkManager
does solve the Problem for me in a nice Gnomish way.

Note You need to log in before you can comment on or make changes to this bug.