Bug 158885 - parted cannot expand ext3 filesystems
parted cannot expand ext3 filesystems
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: parted (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-26 11:49 EDT by Charles C. Figueiredo
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 11:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles C. Figueiredo 2005-05-26 11:49:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:

It appears that parted cannot expand ext3 filesystems:

[root@db6 root]# parted /dev/emcpowerc
GNU Parted 1.6.3
Copyright (C) 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
This program is free software, covered by the GNU General Public License.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for more details.

Using /dev/emcpowerc
(parted) print
Disk geometry for /dev/emcpowerc: 0.000-20480.000 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  10236.730  primary   ext3
(parted) resize 1 0 20480
No Implementation: This ext2 filesystem has a rather strange layout!  Parted can't resize this (yet).
(parted) resize 1 10237 20480
No Implementation: This ext2 filesystem has a rather strange layout!  Parted can't resize this (yet).
(parted) resize 1 1 20480
No Implementation: This ext2 filesystem has a rather strange layout!  Parted can't resize this (yet).
(parted)

The RHEL 3 documentation specifically says to use parted.


Version-Release number of selected component (if applicable):
parted-1.6.3-29.3

How reproducible:
Always

Steps to Reproduce:
1. Expand a LUN on the SAN
2. Verify geometry changed via fdisk/parted
3. Try to resize filesystem
  

Actual Results:  No Implementation: This ext2 filesystem has a rather strange layout!  Parted can't resize this (yet).

Additional info:
Comment 6 David Cantrell 2007-07-23 11:53:08 EDT
Closing this bug as UPSTREAM because of several reasons:

1) I am upstream and we already know about this problem and are working on it.
2) It's now years later and we do not have this functionality in libparted yet.
3) When we do get this functionality, I won't be backporting it to RHEL3, so
this bug won't be really valid.
4) Isn't RHEL3 in security update mode only?  So this won't get rolled in to a
RHEL3 update release anyway.

I'm not sure if UPSTREAM is the right way to close the bug, but the point is we
(upstream parted) are working on it and that will eventually flow down to us in
future releases.  Tracking it as a RHEL bug now doesn't make sense.

Note You need to log in before you can comment on or make changes to this bug.