Bug 15889 - Missing defines from standard #includes
Summary: Missing defines from standard #includes
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Embedded Linux Developer Suite
Classification: Retired
Component: Tools   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: echristo
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-09 20:47 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 18:34:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-09 20:47:40 UTC
the /usr/include tree seems to be missing some #defines - notably

SO_SNDBUF, SO_RCVBUF, and SOL_SOCKET. Is there some reason for this?

Comment 1 Need Real Name 2000-08-09 20:54:50 UTC
Sorry, forgot to include: these are flags/values for setsockopt/getsockopt.
Thanks

Comment 2 echristo 2000-08-10 05:41:32 UTC
These should be defined within <sys/socket.h> via <asm/socket.h>

Are they missing in your headers?

-eric

Comment 3 echristo 2000-08-10 05:41:46 UTC
These should be defined within <sys/socket.h> via <asm/socket.h>

Are they missing in your headers?

-eric

Comment 4 Need Real Name 2000-08-10 18:22:19 UTC
not only are they missing in 6.2, but in 6.1 and FreeBSD's headers as well. Have
not looked at other distros.

Comment 5 echristo 2000-08-10 18:33:57 UTC
This is untrue.  Have you looked in the files that I gave you?  I've checked
this on a couple of boxes.  In addition, this appears to be a question not
related to the EDK and appears to be a question against the distribution?

-eric

------- Additional comments from jbw@syncrasy.com 2000-08-10 02:22 -------

 not only are they missing in 6.2, but in 6.1 and FreeBSD's headers as well.
Have
 not looked at other distros.

Comment 6 Need Real Name 2000-08-10 20:03:39 UTC
OK. Never mind. 8-)
Thanks for the assistance.


Note You need to log in before you can comment on or make changes to this bug.