Bug 158891 - fenced asks for node info which may not exist in all cases during startup
Summary: fenced asks for node info which may not exist in all cases during startup
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On: 158892
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-26 16:26 UTC by Lon Hohberger
Modified: 2009-04-16 20:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 16:42:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed behavior (547 bytes, patch)
2005-05-26 16:26 UTC, Lon Hohberger
no flags Details | Diff

Description Lon Hohberger 2005-05-26 16:26:50 UTC
Description of problem:

Fenced was asking for this from ccsd in order to see if the local node
name was present in the cluster configuration:

    /cluster/clusternodes/clusternode[@name="cyan"]

Unfortunately, because there were no children of that XML node (no
fencing configured), ccsd was crashing (this is a separate issue).

That query doesn't return data in the cases where the local node doesn't
have fencing (which, I know is an unsupported config), but fenced should
be able to fence other nodes even if the local node is running in an
unsupported configuration.  So, it should have been asking for something
which will exist in all fencing cases:

    /cluster/clusternodes/clusternode[@name="cyan"]/@name

Version-Release number of selected component (if applicable):
-RHEL4U1 -RHEL4 -RHEL4


How reproducible: 100%

Steps to Reproduce:
1. Create configuration with no fencing specified for a node.
2. Start fenced.
  
Actual results:
Fenced incorrectly determines that the local node doesn't exist in cluster.conf
(or ccs)


Expected results:


Additional info:

This fix is dependent on a fix to ccsd which prevents it from crashing in this case.

Comment 1 Lon Hohberger 2005-05-26 16:26:51 UTC
Created attachment 114874 [details]
Fixed behavior

Comment 2 Lon Hohberger 2005-05-26 16:30:45 UTC
Adding ccs bug.  Without the fix to ccsd, fenced will produce the error anyway
(because ccsd will crash with SIGSEGV).

Comment 3 Lon Hohberger 2005-05-26 16:59:02 UTC
Patches in CVS


Note You need to log in before you can comment on or make changes to this bug.