Bug 158894 - kernel update 2.6.11-1.1363 breaks ipw-2200
kernel update 2.6.11-1.1363 breaks ipw-2200
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-26 12:46 EDT by Steve Romero
Modified: 2015-01-04 17:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-07 16:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Romero 2005-05-26 12:46:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
kernel update 2.6.11-1.1363 breaks ipw-2200.  Latest kernel update breaks ipw-2200 wireless networking.  Reverting to previous kernel restores the device.

Version-Release number of selected component (if applicable):
Kernel 2.6.11-1.1363_FC4.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1.Install update kernel 2.6.11-1.1363
2.reboot
3.ipw-2200 firmware fails to load

  

Actual Results:  "IPW-2200 Firmware fails to load with Kernel 2.6.11-1.1363"

excerpt from log file:

May 26 09:02:08 S260 kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.0
May 26 09:02:08 S260 kernel: ipw2200: Copyright(c) 2003-2004 Intel Corporation
May 26 09:02:08 S260 kernel: ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 9
May 26 09:02:08 S260 kernel: ACPI: PCI Interrupt 0000:02:0b.0[A] -> Link [LNKD] -> GSI 9 (level, low) -> IRQ 9
May 26 09:02:08 S260 kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
May 26 09:02:08 S260 kernel: ipw2200: ipw-2.2-boot.fw load failed: Reason -2
May 26 09:02:08 S260 kernel: ipw2200: Unable to load firmware: 0xFFFFFFFE
May 26 09:02:08 S260 kernel: ipw2200: failed to register network device
May 26 09:02:08 S260 kernel: ipw2200: probe of 0000:02:0b.0 failed with error -5


Expected Results:  "IPW-2200 Firmware loads normally using Kernel 2.6.11-1.1355"

excerpt from log file:

May 26 09:16:06 S260 kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.4
May 26 09:16:06 S260 kernel: ipw2200: Copyright(c) 2003-2004 Intel Corporation


Additional info:

ipw firmware revision installed is; ipw2200-firmware-2.3.6.at.noarch.rpm

computer is a sony vgn-s270 laptop.
Comment 1 Steve Romero 2005-05-26 17:20:34 EDT
With regards to restoring the device by reverting to kernel 2.6.11-1.1355.  I
should note that I wasn't able to determine if I could actually make a wireless
connection as the facility that I work in prohibits wireless transmission of any
kind.  I'll provide an update after my first opportunity to test.
Comment 2 Warren Togami 2005-05-26 17:23:03 EDT
IPW-2100 and 2200 were reverted in the latest kernel because they conflict with
each other.  Upstream screwed up and we are out of time.  This needs to be fixed
in a FC4Update later.  Sorry about the inconvenience.
Comment 3 Dave Jones 2005-05-26 21:13:12 EDT
most likely you now have a too new firmware for the older driver.
reverting back to the older firmware should fix this.
Comment 4 Steve Romero 2005-05-27 10:43:28 EDT
Thanks for the quick replies and yes I'm sure that you guys are under some real
pressure since final release is scheduled sometime next week.  In any case I'm
sure that things will get worked out in short order.

Regarding using an older firmware version, I was able to get the 2.2.5 firmware
version to install using the "nodep" option.  That however caused Network
Manager to enter some strange state that disabled both eth0 and eth1, eth0 was
up at boot but when I removed eth0 to determine if eth1 would connect it didn't
and in fact it seems that it never initilized (haven't had a chance to go
through the log files to see what really happened but I will get on that later),
this left both eth0 and eth1 disabled.  I tried to renable eth0 manually but
with out success.  I also tried to manually bring eth1 up but that didn't work
either.  The only way to get eth0 back up and restore networking was to reboot.
 The wireless interface, eth1, at this point is a total nogo.  I will try later
this evening to remove Network Manager and try to get things sorted out one step
at a time.  Shame really Network Manager was working really well, the transition
from wired to wireless and back was sweet!  
Comment 5 Steve Romero 2005-05-30 15:43:27 EDT
My work around for ipw2200 driver/firmware issue in FC4 T3

Current kernel version: 2.6.11-1.1365_FC4.i686.rpm
Current Kernel devel: 2.6.11-1.1365_FC4.i686.rpm

Obtained from - http://people.redhat.com/davej/kernels/Fedora/FC4/

Current Network Manager packages: NetworkManager-0.4-15.cvs20050404.i386.rpm
				  NetworkManager-devel-0.4-15.cvs20050404.i386.rpm
				  NetworkManager-glib-0.4-15.cvs20050404.i386.rpm
				  NetworkManager-gnome-0.4-15.cvs20050404.i386.rpm

Current ipw firmware: ipw2200-firmware-2.3-6.at.noarch.rpm

Obtained from http://atrpms.net/dist/common/ipw2200-firmware/

Obtained latest ipw2200 driver from Source Forge: ipw2200-1.0.4.tgz

1) Unpack the ipw2200 driver and execute make as root

2) As root cd to
/lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ieee80211

3) Make directory /save

4) Move all files in
/lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ieee80211 to
/lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ieee80211/save

5) Copy the following files from the ver 1.0.4 driver; ieee80211_crypt_ccmp.ko,
ieee80211_crypt_tkip.ko, ieee80211.ko, ieee80211_crypt.ko, eee80211_crypt_wep.ko
to  /lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ieee80211 

6) As root cd to /lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ipw2200

7) Make directory /save

8) Move ipw2200.ko to
/lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ipw2200/save

9) Copy ipw2200.ko from the ver 1.0.4 driver to
/lib/modules/2.6.11-1.1365_FC4/kernel/drivers/net/wireless/ipw2200

10) Reboot the computer and test.

	a) Verify eth0 is functional

	b) Unplug eth0

	c) Networking fails over to eth1

	d) Plug eth0 back in

	c) Networking at eth0 is restored

Success!  YMMV however...

For reference the relevant excerpt from the log file:

May 30 11:57:14 S260 kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network
Driver, 1.0.4
May 30 11:57:14 S260 kernel: ipw2200: Copyright(c) 2003-2004 Intel Corporation
May 30 11:57:14 S260 kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network
Connection



Comment 6 Steve Romero 2005-05-31 10:27:33 EDT
Additional update:  Updated kernel 2.6.11-1.1366 will also break ipw-2200
operability.  Follow the above steps to restore wireless connectivity.

Comment 7 Steve Romero 2005-06-05 10:44:27 EDT
Just an FYI, my previous comments regarding updated kernels and workaround also
apply to the latest kernel, 2.6.11-1.1369.
Comment 8 Steve Romero 2005-06-05 17:32:14 EDT
With regards to my last comment.  I may have been a bit premature it seems that
when I tested last night it seemed to work albeit it was a slow connection,
email web, I just blew it off thinking that this was another ISP issue.  However
this afternoon I was unable to connect via wireless and the log showed numerous
errors regarding firmware failure and reconnecting.  After rebooting however the
firmware fails to load at all indicating the same log errors previously
mentioned in my original post:

Jun  5 14:01:08 S260 kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network
Driver, 1.0.0
Jun  5 14:01:08 S260 kernel: ipw2200: Copyright(c) 2003-2004 Intel Corporation
Jun  5 14:01:08 S260 kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network
Connection
Jun  5 14:01:08 S260 kernel: ipw2200: ipw-2.2-boot.fw load failed: Reason -2
Jun  5 14:01:08 S260 kernel: ipw2200: Unable to load firmware: 0xFFFFFFFE
Jun  5 14:01:08 S260 kernel: ipw2200: failed to register network device
Jun  5 14:01:08 S260 kernel: ipw2200: probe of 0000:02:0b.0 failed with error -5

Perhaps I shouldn't test after a couple of beers!

In any case reverting to the 1366 kernel restored wireless capability.

I'll look into working with the 1369 kernel later but after trying, not too
successfully, to get hsfmodem and mplayer working I think I'll call it a day.
Comment 9 Steve Romero 2005-06-08 20:40:19 EDT
Follow-up regarding kernel 2.6.11-1.1369 and ipw-2200 wireless networking.  I
was able to resolve a working configuration today by doing the following:

1.  Obtain ipw2200 firmware version 2.2 from sourceforge.

2.  Extract the files and as root copy the files to /lib/firmware.

3.  As root cd to /lib/firmware and execute the following:

	a) chmod 755 *

	b) chown root *

	c) chgrp root *

4.  As I had previously moved the original drivers that were installed with the
1369 kernel to a save directory I copied them back to their original locations.

NOTE:  That I also had to edit /lib/modules/2.6.11-1.1369_FC4/modules.dep to
remove the */save/* path from the modules dependencies.  Not exactly sure why or
how this file discovered this but nonetheless if you've followed any of my
previous workarounds you may also have to do this.

5.  Reboot and test.

Things seem to be working, NetworkManager transitions from wired to wireless and
back again with no problem.  And both network connections seem to function just
fine.

Also of note regarding the ipw2200 Atrpm firmware package.  For whatever reason
I had to get the firmware package from sourceforge I simply can't get the rpm to
work?  They are I presume the same files but for whatever reason they don't work
for me, bad karma?

Comment 10 Dave Jones 2005-06-27 19:13:46 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 11 Steve Romero 2005-06-29 20:44:50 EDT
Have finally gotten around to installing FC4 release and all seems to work,
albeit a bit differently than the test versions, e.g. I have to select,
identify, and enter a passphrase, key each time but it does work.
Comment 12 Isaac Overcast 2005-10-05 17:13:53 EDT
Just wanted to let you know i had a similar problem with ipw-2200 and kernel
2.6.11-1.1369_FC4. I obtained the proper firmware (ipw-2.2) from
ipw2200.sourceforge.net and put them in /lib/firmware. Reboot! Everything seems
fine now.

Just out of curiousity: This was from the current release version (Fedora Core
4). Is this bug closed because we all know about it now and it's going to be
fixed in a future release? I don't know anything about your development
process/bugtracking business.

anyway, thanks for all your great work,
-isaac


(In reply to comment #9)
> Follow-up regarding kernel 2.6.11-1.1369 and ipw-2200 wireless networking.  I
> was able to resolve a working configuration today by doing the following:
> 
> 1.  Obtain ipw2200 firmware version 2.2 from sourceforge.
> 
> 2.  Extract the files and as root copy the files to /lib/firmware.
> 
> 3.  As root cd to /lib/firmware and execute the following:
> 
> 	a) chmod 755 *
> 
> 	b) chown root *
> 
> 	c) chgrp root *
> 
> 4.  As I had previously moved the original drivers that were installed with the
> 1369 kernel to a save directory I copied them back to their original locations.
> 
> NOTE:  That I also had to edit /lib/modules/2.6.11-1.1369_FC4/modules.dep to
> remove the */save/* path from the modules dependencies.  Not exactly sure why or
> how this file discovered this but nonetheless if you've followed any of my
> previous workarounds you may also have to do this.
> 
> 5.  Reboot and test.
> 
> Things seem to be working, NetworkManager transitions from wired to wireless and
> back again with no problem.  And both network connections seem to function just
> fine.
> 
> Also of note regarding the ipw2200 Atrpm firmware package.  For whatever reason
> I had to get the firmware package from sourceforge I simply can't get the rpm to
> work?  They are I presume the same files but for whatever reason they don't work
> for me, bad karma?
> 
> 

Note You need to log in before you can comment on or make changes to this bug.