Bug 158990 - dmidecode memory fault on TYAN CK804 with 2 2.4Ghz AMD Opteron 250 processors
Summary: dmidecode memory fault on TYAN CK804 with 2 2.4Ghz AMD Opteron 250 processors
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 168991 (view as bug list)
Depends On:
Blocks: 168424
TreeView+ depends on / blocked
 
Reported: 2005-05-27 14:55 UTC by john.blackwood
Modified: 2015-01-04 22:19 UTC (History)
3 users (show)

Fixed In Version: RHBA-2006-0014
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 15:40:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode v2.6 complete output (12.83 KB, text/plain)
2005-05-27 14:59 UTC, john.blackwood
no flags Details
partial output from dmidecode - rpm version 8.37.12 x86_64 (5.00 KB, text/plain)
2005-05-27 15:01 UTC, john.blackwood
no flags Details
fix dmidecode segfault on non-ascii dmi_string (697 bytes, patch)
2005-06-28 14:44 UTC, Guy Streeter
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0014 qe-ready SHIPPED_LIVE kernel-utils bugfix update 2006-03-14 05:00:00 UTC

Description john.blackwood 2005-05-27 14:55:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.4) Gecko/20050318 Red Hat/1.4.4-1.3.5

Description of problem:
When we run 'dmidecode' on a Celestica Model A2210 Dual Opteron Server
(x86_64) with the latest:

    kernel-utils-2.4-8.37.12.x86_64.rpm

version, we get a "Memory fault", and the output from dmidecode is
not complete.

We are running the following RHEL 3.0 U4 kernel:

> uname -a
  Linux opteron2 2.4.21-27.0.4.ELsmp #1 SMP
  Sat Apr 16 18:53:14 EDT 2005 x86_64 x86_64 x86_64 GNU/Linux

------------------------------------------------------------------
Side note:

  We noticed the https://rhn.redhat.com/errata/RHBA-2005-228.html
  errata posting and then pulled in this corresponding
  kernel-utils-2.4-8.37.12.x86_64.rpm.

  The previous version that we were using, kernel-utils-2.4-8.37.7,
  would oops the system with a corrupted page table:

     dmidecode: Corrupted page table at address 2a9556d001
     PML4 7c2ba067 PGD 7c2c9067 PMD 7bdc3067 PTE ffffffffaff7b025
     Bad pagetable: 000d [1] PREEMPT SMP
----------------------------------------------------------------------

Additional info:

We downloaded dmidecode versions 2.2, 2.3, 2.4, 2.5 and 2.6
from http://www.nongnu.org/dmidecode/ and ran each version.

While version 2.2 also will oops the system with the Corrupted page table
problem, all other versions (2.3 through 2.6) function properly on this
Celestica system (ignoring some CPU changes/fixes to the output between
dmidecode versions 2.3 and 2.4).

----------------------------------------------------------------------

The kernel-utils 8.37.12 dmidecode version "Memory fault" seems to occur
when it is attempting to output:

Handle 0x000C
        DMI type 11, 5 bytes.
        OEM Strings
                String 1: 0
                String 2: 0
                String 3: .........................

And instead, we only see:

Handle 0x000C
        DMI type 11, 5 bytes.
        OEM Strings
                String 1: 0
                String 2: 0
Memory fault


I am attaching the complete output from a dmidecode version 2.6
run, and the partial output of the dmidecode version that is in
kernel-utils-2.4-8.37.12.x86_64.rpm.




Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.12.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1.just run 'dmidecode'
2.
3.
  

Additional info:

Comment 1 john.blackwood 2005-05-27 14:59:58 UTC
Created attachment 114914 [details]
dmidecode v2.6 complete output

Comment 2 john.blackwood 2005-05-27 15:01:55 UTC
Created attachment 114915 [details]
partial output from dmidecode - rpm version 8.37.12 x86_64

Comment 3 john.blackwood 2005-05-27 17:45:15 UTC
I'm afraid that I completely botched up the system name in the initial creation
of this bugzilla.

Instead of "Celestica Model A2210", I should have said:

  TYAN CK804 with 2 2.4Ghz AMD Opteron 250 processors

as the output from dmidecode shows.

Sorry for my confusion.


Comment 4 Guy Streeter 2005-06-28 14:44:45 UTC
Created attachment 116062 [details]
fix dmidecode segfault on non-ascii dmi_string

Comment 5 Guy Streeter 2005-06-28 14:46:59 UTC
The code to convert non-ASCII characters to '.' characters tries to write to a
read-only mmapped area.
I have attached a patch that is one way of fixing it.

Comment 11 Linda Wang 2005-10-03 15:53:27 UTC
*** Bug 168991 has been marked as a duplicate of this bug. ***

Comment 19 Red Hat Bugzilla 2006-03-15 15:40:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0014.html



Note You need to log in before you can comment on or make changes to this bug.