Bug 159090 - libtool files (.la) refer to a missing libfam.la and block amaroK's build
Summary: libtool files (.la) refer to a missing libfam.la and block amaroK's build
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-29 08:20 UTC by Aurelien Bompard
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-30 12:24:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to solve broke gamin package (369 bytes, patch)
2005-05-30 18:05 UTC, Jochen Schmitt
no flags Details | Diff

Description Aurelien Bompard 2005-05-29 08:20:08 UTC
Description of problem:

/usr/lib/libk*.la files refer to /usr/lib/libfam.la, but it does not exist
anymore in the gamin-devel package. As a consequence, amaroK won't build on rawhide.
A "grep -l libfam.la /usr/lib/*.la" will give you the list of affected files, I
won't paste it here because there are 70 of them.


Version-Release number of selected component (if applicable):
kdelibs-3.4.0-6

How reproducible:
Always

Steps to Reproduce:
1. Try to build amaroK from extras on the devel branch
2. Message : 
/bin/sh ../../../../libtool --silent --mode=link --tag=CXX g++ [...SNIP...]
grep: /usr/lib/libfam.la: No such file or directory
/bin/sed: can't read /usr/lib/libfam.la: No such file or directory
libtool: link: `/usr/lib/libfam.la' is not a valid libtool archive
make[6]: *** [libamarok_gstengine_plugin.la] Error 1

Comment 1 Ville Skyttä 2005-05-30 16:50:12 UTC
See bug 159144.

Comment 2 Jochen Schmitt 2005-05-30 18:05:13 UTC
Created attachment 114975 [details]
Patch to solve broke gamin package

Patch should solve the problems coused by the broken gamin package.

Comment 3 Jochen Schmitt 2005-06-02 16:47:11 UTC
Comment on attachment 114975 [details]
Patch to solve broke gamin package

>--- gamin.spec	2005-05-30 19:49:58.000000000 +0200
>+++ gamin.spec.~1.31.~	2005-05-12 16:00:47.000000000 +0200
>@@ -50,6 +50,7 @@
> rm -fr %{buildroot}
> 
> %makeinstall
>-rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
> 
> %clean
> rm -fr %{buildroot}
>@@ -68,7 +69,6 @@
> %doc doc/*.gif
> %doc doc/*.txt
> %{_libdir}/lib*.so.*
>+%{_libdir}/lib*.la
> %{_libexecdir}/gam_server
> 
> %files devel

Comment 4 Jochen Schmitt 2005-06-02 16:49:25 UTC
Relating to comment #3.

Accidendly, I have create the patch in the revert order.

Sorry for any inconviniece.

Best Regards:

Jochen Schmitt

Comment 5 Rex Dieter 2005-06-30 12:13:19 UTC
IMO, this is NOTABUG (not a gamin one anyway).  gamin shouldn't provide 
libfam.la (it's not really needed).  Packages/other-.la-files that currently 
reference the missing libfam.la simply need to be rebuilt.  

In the meantime, the quick-n-dirty fix is:
perl -pi -e "s@/usr/lib/libfam.la@@g" /usr/lib/*.la

Comment 6 Ngo Than 2005-06-30 12:24:35 UTC
We have added .la files in gamin package back in FC4 release. For FC5 they will
be removed.


Note You need to log in before you can comment on or make changes to this bug.