Bug 159111 - Installer activates lvm
Installer activates lvm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-29 21:31 EDT by peter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-30 23:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter 2005-05-29 21:31:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Hi ??,
I just installed the fedora4 test3 onto a new system.  It has automatically activated the LVM feature.  Whilst LVM is a desirable feature and may wanted on many systems not all systems will want it.  I did not and I am still trying to work out how to deactivate it.  Since it activated it on the root filesystem this is particularly hazardous.  (In fact currently the system panics on startup).

I believe a choice should be given, maybe the default to enable LVM, but it should not be forced.  For the system I am creating the use of LVM is not only unwanted but undesirable as well.

(PS This may not technically be a bug but I could not find any other way to report it)

Thankz Zach

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1) Get hardware to build new system from scratch
2) Boot from CD and install


Additional info:
Comment 1 Jeremy Katz 2005-05-30 23:06:56 EDT
We do LVM by default to make things better if you add a disk later or need to do
partition resizing.
Comment 2 peter 2005-05-31 19:15:05 EDT
Hi ..

This does not address the issue.  It should not be forced on people, this is a
windows mentality.  I need/want the ability to physically move drives from 1
computer to another.  I can not do this if LVM is activated on these systems. 
If I am not given the option of not using LVM I will need to either start using
windows based systems again or possibly but less likely start using another
linux distro.  

For this particular system I was creating, for demonstration purposes, I have
installed windows and will be selling a windows system.

Zach
Comment 3 Paul Nasrat 2005-05-31 19:54:54 EDT
You can choose to manually partition, and thus not use LVM.  

You can also choose to edit the automatically created partitions and re partition.

You can also choose to use kickstart and specify the partition layout in ks.cfg.
Comment 4 peter 2005-05-31 22:28:07 EDT
Thanks Paul,

I did manually partition the hard drive during the install process. But it then
activated LVM anyway.  How do I use kickstart when doing a completely clean
install to the system not to activate LVM. 

What I want, during the install process, is to end up with 3 partitions.
1)  root partition where Fedora has installed everything to.
    This would be either ext2 or ext3 but not LVM.
2)  A swap partition
3)  A data partition.

In most cases the root partition and the data partition would be on seperate
physical disks.  I often then remove the device in the data partition and put it
into a different machine.  Because of this type of process I don't want LVM
active.  

(I can try the install again, on my test machine, if you can indicate what I can
do stop LVM being activated).

Cheers Zach 
Comment 5 Paul Nasrat 2005-06-01 07:37:14 EDT
Can you clarify what you mean by activate LVM.  If you manually partition you
should get what you ask for.  

Particularly if you're going to be building lots of machines and use kickstart.
 The easiest method is look in /root/anaconda-ks.cfg on the install machine for
a base ks.cfg

Some documentation of RHEL that will be useful:

http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/ch-kickstart2.html

The options for ks.cfg and an advanced partitioning example:

http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/s1-kickstart2-options.html#S2-KICKSTART2-OPTIONS-PART-EXAMPLES

Further questions can be asked on kickstart-list 

http://www.redhat.com/mailman/listinfo/kickstart-list/

Note You need to log in before you can comment on or make changes to this bug.