Bug 15913 - X server crashes with keyboard switcher
X server crashes with keyboard switcher
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 05:16 EDT by rjb
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 12:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rjb 2000-08-10 05:16:56 EDT
Using a BELKIN Omni Cube 4-port keyboard/mouse/monitor switcher on a 
redhat linux machine with Xfree86-Mach64-3.3.6-20 X server.  Switching to 
and from the linux machine can sometimes (quite frequently) hang the X 
server.

The linux console drivers are not affected.  Windows machines are not 
affected.  The problem only appears to affect X servers.  This problem 
reduces the effectiveness of linux machines as servers since a single 
operator station cannot be used to manage many linux servers as it can 
with many windows servers.
Comment 1 Mike A. Harris 2000-12-05 02:59:55 EST
Is this keyboard switcher mechanical or electronic?  Ie: Does it have
a power cable or power adaptor?  Are the keyboards standard AT style or
PS/2?  Are the mice serial or PS/2?  Any additional info you can provide
may help to pinpoint the problem?  What version of XFree86 are you using?
Please indicate the exact Red Hat package name/version/release if you can.
Comment 2 rjb 2000-12-05 05:20:17 EST
The keyboard switcher is powered.  All devices are PS/2.  The keyboard
switcher also intercepts the keyboard in some way.  <scrlk><scrlk><digit> can 
be used to switch between computers.

 $  rpm -q -a | grep XFree86
XFree86-xfs-3.3.6-20
XFree86-FBDev-3.3.6-20
XFree86-Mach64-3.3.6-20
XFree86-75dpi-fonts-3.3.6-20
XFree86-ISO8859-2-1.0-9
XFree86-VGA16-3.3.6-20
XFree86-ISO8859-9-2.1.2-10
XFree86-ISO8859-2-100dpi-fonts-1.0-9
XFree86-ISO8859-2-75dpi-fonts-1.0-9
XFree86-ISO8859-2-Type1-fonts-1.0-9
XFree86-ISO8859-7-1.0-4
XFree86-ISO8859-7-100dpi-fonts-1.0-4
XFree86-ISO8859-7-75dpi-fonts-1.0-4
XFree86-ISO8859-7-Type1-fonts-1.0-4
XFree86-Xnest-3.3.6-20
XFree86-ISO8859-9-100dpi-fonts-2.1.2-10
XFree86-ISO8859-9-75dpi-fonts-2.1.2-10
XFree86-Xvfb-3.3.6-20
XFree86-cyrillic-fonts-3.3.6-20
XFree86-doc-3.3.6-20
XFree86-libs-3.3.6-20
XFree86-3.3.6-20
XFree86-100dpi-fonts-3.3.6-20
XFree86-XF86Setup-3.3.6-20
XFree86-devel-3.3.6-20
Comment 3 Mike A. Harris 2001-03-08 05:23:09 EST
Please try the latest version of XFree86 from:

ftp://people.redhat.com/mharris/xfree86

Does it fix the problem?  If not, then it is a problem intrinsic to
XFree86 in general, and you should contact the XFree86 team about a possible
fix.  bugs@xfree86.org

I do not have such a switcher to test with, although I have used
a switchbox before that worked fine (mechanical).
Comment 4 Mike A. Harris 2001-05-20 18:46:57 EDT
Closing bug due to lack of feedback.

Note You need to log in before you can comment on or make changes to this bug.